Fortinet FortiOS sslvpnd远程代码执行漏洞(CVE-2022-42475)安全风险通告

admin 2022年12月25日01:07:26安全漏洞评论56 views2180字阅读7分16秒阅读模式
Fortinet FortiOS sslvpnd远程代码执行漏洞(CVE-2022-42475)安全风险通告

奇安信CERT

致力于第一时间为企业级用户提供安全风险通告有效解决方案。




安全通告



Fortinet FortiOS 是美国飞塔(Fortinet)公司的一套专用于 FortiGate 网络安全平台上的安全操作系统。该系统为用户提供防火墙、防病毒、IPSec/SSLVPN、Web内容过滤和反垃圾邮件等多种安全功能。

近日,奇安信CERT监测到 Fortinet FortiOS sslvpnd远程代码执行漏洞,FortiOS sslvpnd存在堆溢出漏洞,未经身份验证的远程攻击者通过特制请求触发堆溢出,从而在目标系统上执行任意代码或命令。该漏洞影响Fortinet防火墙和SSL VPN等产品,目前已监测到该漏洞的在野利用。鉴于该漏洞影响范围极大,建议客户尽快做好自查及防护。

漏洞名称

Fortinet FortiOS sslvpnd远程代码执行漏洞

公开时间

2022-12-12

更新时间

2022-12-13

CVE编号

CVE-2022-42475

其他编号

QVD-2022-46336

威胁类型

代码执行、命令执行

技术类型

堆溢出

厂商

Fortinet

产品

FortiOS、FortiOS-6K7K

风险等级

奇安信CERT风险评级

风险等级

高危

蓝色(一般事件)

现时威胁状态

POC状态

EXP状态

在野利用状态

技术细节状态

未发现

未发现

已发现

未公开

漏洞描述

FortiOS sslvpnd存在堆溢出漏洞,未经身份验证的远程攻击者通过发送特制请求触发堆溢出,从而在目标系统上执行任意代码或命令。

影响版本

7.2.0 <= FortiOS <= 7.2.2
7.0.0 <= FortiOS <= 7.0.8
6.4.0 <= FortiOS <= 6.4.10
6.2.0 <= FortiOS <= 6.2.11
7.0.0 <= FortiOS-6K7K <= 7.0.7
6.4.0 <= FortiOS-6K7K <= 6.4.9
6.2.0 <= FortiOS-6K7K <= 6.2.11
6.0.0 <= FortiOS-6K7K <= 6.0.14

不受影响版本

FortiOS >= 7.2.3

FortiOS >= 7.0.9

FortiOS >= 6.4.11

FortiOS >= 6.2.12

FortiOS-6K7K >= 7.0.8

FortiOS-6K7K >= 6.4.10

FortiOS-6K7K >= 6.2.12

FortiOS-6K7K >= 6.0.15

其他受影响组件

Fortinet SSL VPN、Fortinet 防火墙等使用了sslvpnd的组件



威胁评估

漏洞名称

Fortinet FortiOS sslvpnd远程代码执行漏洞

CVE编号

CVE-2022-42475

其他编号

QVD-2022-46336

CVSS 3.1评级

高危

CVSS 3.1分数

9.8

CVSS向量

访问途径(AV

攻击复杂度(AC

网络

所需权限(PR

用户交互(UI

不需要

影响范围(S

机密性影响(C

不改变

完整性影响(I

可用性影响(A

危害描述

未经身份验证的远程攻击者可以通过发送特制请求触发堆溢出,在目标系统执行任意代码或命令,完全控制目标设备。



处置建议

1、升级安全版本

官方已发布安全更新,可以通过升级到以下版本修复漏洞:
FortiOS >= 7.2.3
FortiOS >= 7.0.9
FortiOS >= 6.4.11
FortiOS >= 6.2.12
FortiOS-6K7K >= 7.0.8
FortiOS-6K7K >= 6.4.10
FortiOS-6K7K >= 6.2.12
FortiOS-6K7K >= 6.0.15


2、攻击排查建议

官方已发布目前在野利用监测的IOC:
  • 检查系统中是否存在以下文件:

/data/lib/libips.bak
/data/lib/libgif.so
/data/lib/libiptcp.so
/data/lib/libipudp.so
/data/lib/libjepg.so
/var/.sslvpnconfigbk
/data/etc/wxd.conf
/flash
可通过以下命令进行检查:
diagnose sys last-modified-files /data/libdiagnose sys last-modified-files /var/diagnose sys last-modified-files /data/etc/diagnose sys last-modified-files /flash
  • 检查是否存在下列日志项

Logdesc="Application crashed" and msg="[...] application:sslvpnd,[...], Signal 11 received, Backtrace: [...]"
  • 检查FortiGate是否存在以下IP的TCP连接:

188.34.130.40:444103.131.189.143:30080,30081,30443,20443192.36.119.61:8443,444172.247.168.153:8033


参考资料

[1]https://www.fortiguard.com/psirt/FG-IR-22-398



时间线

2022年12月13日,奇安信 CERT发布安全风险通告


点击阅读原文

到奇安信NOX-安全监测平台查询更多漏洞详情

原文始发于微信公众号(奇安信 CERT):Fortinet FortiOS sslvpnd远程代码执行漏洞(CVE-2022-42475)安全风险通告

特别标注: 本站(CN-SEC.COM)所有文章仅供技术研究,若将其信息做其他用途,由用户承担全部法律及连带责任,本站不承担任何法律及连带责任,请遵守中华人民共和国安全法.
  • 我的微信
  • 微信扫一扫
  • weinxin
  • 我的微信公众号
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2022年12月25日01:07:26
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                  Fortinet FortiOS sslvpnd远程代码执行漏洞(CVE-2022-42475)安全风险通告 http://cn-sec.com/archives/1461344.html

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: