Vulmap:一款功能强大的Web漏洞扫描和验证工具

  • A+
所属分类:安全工具

Vulmap:一款功能强大的Web漏洞扫描和验证工具

Vulmap

Vulmap是一款功能强大的Web漏洞扫描和验证工具,该工具可以对Web容器、Web服务器、Web中间件以及CMS等Web程序进行漏洞扫描,并且具备漏洞利用功能。广大安全研究人员可以使用Vulmap检测目标是否存在特定漏洞,并且可以使用漏洞利用功能验证漏洞是否真实存在。

Vulmap目前有漏洞扫描(poc)和漏洞利用(exp)模式, 使用”-m”选现指定使用哪个模式, 缺省则默认poc模式, 在poc模式中还支持”-f”批量目标扫描、”-o”文件输出结果等主要功能, 更多功能参见options或者python3 vulmap.py -h, 漏洞利用exp模式中将不再提供poc功能, 而是直接进行漏洞利用, 并反馈回利用结果, 用于进一步验证漏洞是否存在, 是否可被利用。

工具安装

首先,我们需要在本地系统中安装并配置好Python 3环境,我们推荐使用Python 3.7或更高版本。

广大研究人员可以使用下列命令将该项目源码克隆至本地,并完成依赖组件和工具的安装配置:

git clone https://github.com/zhzyker/vulmap.git# 安装所需的依赖环境pip install -r requirements.txt# Linux & MacOS & Windowspython vulmap.py -u http://example.com

工具选项

可选参数:
-h, --help 显示此帮助消息并退出
-u URL, --url URL 目标 URL (示例: -u "http://example.com")
-f FILE, --file FILE 选择一个目标列表文件,每个 url 必须用行来区分 (示例: -f "/home/user/list.txt")
-m MODE, --mode MODE 模式支持 "poc" 和 "exp",可以省略此选项,默认进入 "poc" 模式
-a APP, --app APP 指定 Web 容器、Web 服务器、Web 中间件或 CMD(例如: "weblogic")不指定则默认扫描全部
-c CMD, --cmd CMD 自定义远程命令执行执行的命令,默认是echo
-v VULN, --vuln VULN 利用漏洞,需要指定漏洞编号 (示例: -v "CVE-2020-2729")
-o, --output FILE 文本模式输出结果 (示例: -o "result.txt")
--list 显示支持的漏洞列表
--debug Debug 模式,将显示 request 和 responses
--delay DELAY 延时时间,每隔多久发送一次,默认0s
--timeout TIMEOUT 超时时间,默认10s

工具使用样例

测试所有漏洞 PoC:

python3 vulmap.py -u http://example.com

针对 RCE 漏洞,自定义命令检测是否存在漏洞,例如针对没有回现的漏洞使用DNSlog:

python3 vulmap.py -u http://example.com -c "ping xxx.xxx"

检查 http://example.com 是否存在 struts2 漏洞:

python3 vulmap.py -u http://example.com -a struts2python3 vulmap.py -u http://example.com -m poc -a struts2

对 http://example.com:7001 进行 WebLogic 的 CVE-2019-2729 漏洞利用:

python3 vulmap.py -u http://example.com:7001 -v CVE-2019-2729python3 vulmap.py -u http://example.com:7001 -m exp -v CVE-2019-2729

批量扫描 list.txt 中的 url:

python3 vulmap.py -f list.txt

扫描结果导出到 result.txt:

python3 vulmap.py -u http://example.com:7001 -o result.txt

支持的漏洞列表

8.5.3 (except 8.4.8) drupalgeddon2 rce            |
| Drupal | CVE-2019-6340 | Y | Y | < 8.6.10, drupal core restful remote code execution |
| Elasticsearch | CVE-2014-3120 | Y | Y | < 1.2, elasticsearch remote code execution |
| Elasticsearch | CVE-2015-1427 | Y | Y | 1.4.0 < 1.4.3, elasticsearch remote code execution |
| Jenkins | CVE-2017-1000353 | Y | N | <= 2.56, LTS <= 2.46.1, jenkins-ci remote code execution |
| Jenkins | CVE-2018-1000861 | Y | Y | <= 2.153, LTS <= 2.138.3, remote code execution |
| Nexus OSS/Pro | CVE-2019-7238 | Y | Y | 3.6.2 - 3.14.0, remote code execution vulnerability |
| Nexus OSS/Pro | CVE-2020-10199 | Y | Y | 3.x <= 3.21.1, remote code execution vulnerability |
| Oracle Weblogic | CVE-2014-4210 | Y | N | 10.0.2 - 10.3.6, weblogic ssrf vulnerability |
| Oracle Weblogic | CVE-2017-3506 | Y | Y | 10.3.6.0, 12.1.3.0, 12.2.1.0-2, weblogic wls-wsat rce |
| Oracle Weblogic | CVE-2017-10271 | Y | Y | 10.3.6.0, 12.1.3.0, 12.2.1.1-2, weblogic wls-wsat rce |
| Oracle Weblogic | CVE-2018-2894 | Y | Y | 12.1.3.0, 12.2.1.2-3, deserialization any file upload |
| Oracle Weblogic | CVE-2019-2725 | Y | Y | 10.3.6.0, 12.1.3.0, weblogic wls9-async deserialization rce |
| Oracle Weblogic | CVE-2019-2729 | Y | Y | 10.3.6.0, 12.1.3.0, 12.2.1.3 wls9-async deserialization rce |
| Oracle Weblogic | CVE-2020-2551 | Y | N | 10.3.6.0, 12.1.3.0, 12.2.1.3-4, wlscore deserialization rce |
| Oracle Weblogic | CVE-2020-2555 | Y | Y | 3.7.1.17, 12.1.3.0.0, 12.2.1.3-4.0, t3 deserialization rce |
| Oracle Weblogic | CVE-2020-2883 | Y | Y | 10.3.6.0, 12.1.3.0, 12.2.1.3-4, iiop t3 deserialization rce |
| Oracle Weblogic | CVE-2020-14882 | Y | Y | 10.3.6.0, 12.1.3.0, 12.2.1.3-4, 14.1.1.0.0, console rce |
| RedHat JBoss | CVE-2010-0738 | Y | Y | 4.2.0 - 4.3.0, jmx-console deserialization any files upload |
| RedHat JBoss | CVE-2010-1428 | Y | Y | 4.2.0 - 4.3.0, web-console deserialization any files upload |
| RedHat JBoss | CVE-2015-7501 | Y | Y | 5.x, 6.x, jmxinvokerservlet deserialization any file upload |
| ThinkPHP | CVE-2019-9082 | Y | Y | < 3.2.4, thinkphp rememberme deserialization rce |
| ThinkPHP | CVE-2018-20062 | Y | Y | <= 5.0.23, 5.1.31, thinkphp rememberme deserialization rce |
+-------------------+------------------+-----+-----+-------------------------------------------------------------+
Vulmap:一款功能强大的Web漏洞扫描和验证工具

精彩推荐





Vulmap:一款功能强大的Web漏洞扫描和验证工具
Vulmap:一款功能强大的Web漏洞扫描和验证工具Vulmap:一款功能强大的Web漏洞扫描和验证工具


Vulmap:一款功能强大的Web漏洞扫描和验证工具

Vulmap:一款功能强大的Web漏洞扫描和验证工具

Vulmap:一款功能强大的Web漏洞扫描和验证工具

Vulmap:一款功能强大的Web漏洞扫描和验证工具

本文始发于微信公众号(FreeBuf):Vulmap:一款功能强大的Web漏洞扫描和验证工具

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: