PHP CGI Windows平台远程代码执行漏洞(CVE-2024-4577)

admin 2024年6月8日20:02:58评论6 views字数 711阅读2分22秒阅读模式

2024年6月6日,PHP官方发布新版本,修复 CVE-2024-4577 PHP CGI Windows平台远程代码执行漏洞。

01

PHP 在设计时忽略 Windows 中对字符转换的Best-Fit 特性,当 PHP-CGI 运行在Window平台且使用了如下语系(简体中文936/繁体中文950/日文932等)时,攻击者可构造恶意请求绕过 CVE-2012-1823 补丁,从而可在无需登陆的情况下执行任意PHP代码。

2024年6月6日,PHP官方发布新版本正式修复该漏洞,2024年6月7日,阿里云安全工程师已完成对该漏洞的分析以及复现,漏洞利用较为简单且危害较大,建议尽快采取措施升级或者进行缓解。

漏洞复现如下:

PHP CGI Windows平台远程代码执行漏洞(CVE-2024-4577)

02

CVE-2024-4577 PHP CGI Windows平台远程代码执行漏洞 严重

03

影响范围

PHP 8.3 < 8.3.8 

PHP 8.2 < 8.2.20 

PHP 8.1 < 8.1.29 

针对其他版本,PHP官方已不在维护,建议根据实际情况采取相应缓解措施。

04

1、官方已发布安全更新,建议升级至最新版本。

2、若无法更新至新版本,且若PHP运行于Window平台上,建议关闭php-cgi的使用。

3、阿里云云安全中心应用漏洞、应急漏洞已于2024年6月7日上线针对该漏洞的检测规则。

05

https://avd.aliyun.com/detail/AVD-2024-4577

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2024-4577

原文始发于微信公众号(阿里云应急响应):PHP CGI Windows平台远程代码执行漏洞(CVE-2024-4577)

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2024年6月8日20:02:58
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   PHP CGI Windows平台远程代码执行漏洞(CVE-2024-4577)https://cn-sec.com/archives/2827751.html

发表评论

匿名网友 填写信息