OpenSSH 远程代码执行漏洞(CVE-2024-6387)

admin 2024年7月2日14:23:46评论18 views字数 694阅读2分18秒阅读模式
一、漏洞描述

OpenSSH是一套基于SSH协议的安全网络实用程序,它提供强大的加密功能以确保隐私和安全的文件传输,使其成为远程服务器管理和安全数据通信的必备工具。

近日,中睿天下安全团队监测到OpenSSH Server存在远程代码执行漏洞。该漏洞是由于OpenSSH服务器 (sshd) 中的信号处理程序竞争问题,未经身份验证的攻击者可以利用此漏洞在Linux系统上以root身份执行任意代码。

鉴于该漏洞影响较大,建议客户尽快做好自查及防护。

二、漏洞信息
01
 漏洞详情
OpenSSH 远程代码执行漏洞(CVE-2024-6387)
三、影响范围
01
影响版本范围

OpenSSH < 4.4p1(除非已经打过漏洞CVE-2006-5051 和 CVE-2008-4109的相关补丁)

8.5p1 <= OpenSSH < 9.8p1

02
资产使用情况
根据指纹特征,通过资产测绘系统发现,全球共779331条受影响版本的OpenSSH 使用记录,其中中国有30521条使用记录。

OpenSSH 远程代码执行漏洞(CVE-2024-6387)

四、修复建议
01
官方修复建议

目前官方已有可更新版本,建议受影响用户升级至最新版本。

官方补丁下载地址:

https://www.openssh.com/releasenotes.html

02
临时措施

可以通过验证所安装的 OpenSSH Server版本来确定其系统是否易受攻击,如确认受影响可及时更新,尤其是面向互联网的资产。

如果 sshd 无法更新或重新编译,可在配置文件中将 LoginGraceTime 设置为 0,这会耗尽所有 MaxStartups 连接,从而使sshd 容易受到拒绝服务攻击,但可以缓解该RCE风险。

原文始发于微信公众号(蓝鸟安全):安全通告 | OpenSSH 远程代码执行漏洞(CVE-2024-6387)

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2024年7月2日14:23:46
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   OpenSSH 远程代码执行漏洞(CVE-2024-6387)http://cn-sec.com/archives/2909417.html

发表评论

匿名网友 填写信息