Apache HTTP Server源代码泄露漏洞安全风险通告

admin 2024年7月8日11:33:47评论6 views字数 670阅读2分14秒阅读模式
漏洞背景
近日,嘉诚安全监测到Apache HTTP Server中存在一个源代码泄露漏洞,漏洞编号为:CVE-2024-39884。Apache HTTP Server是美国阿帕奇(Apache)基金会的一款开源网页服务器,ap_set_content_type函数用于设置请求的content-type

鉴于漏洞危害较大,嘉诚安全提醒相关用户尽快更新至安全版本,避免引发漏洞相关的网络安全事件。

漏洞详情
经研判,该漏洞为高危漏洞。受影响版本中ap_set_content_type函数未正确校验content-type的来源,在某些间接请求文件的情况下,AddType及类似配置会导致本地脚本文件的内容泄露,攻击者可能利用该漏洞获取php等脚本语言源代码。修复版本通过替换函数ap_set_content_type为ap_set_content_type_ex,并增加额外的参数,确保content-type被正确地识别和处理,从而避免PHP脚本等内容未经解析直接输出。
危害影响
影响版本:Apache HTTP Server 2.4.60

处置建议
目前该漏洞已经修复,受影响用户可升级到以下版本:Apache HTTP Server >=2.4.61

下载链接:

https://httpd.apache.org/download.cgi

参考链接:

https://httpd.apache.org/security/vulnerabilities_24.html

原文始发于微信公众号(嘉诚安全):【漏洞通告】Apache HTTP Server源代码泄露漏洞安全风险通告

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2024年7月8日11:33:47
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   Apache HTTP Server源代码泄露漏洞安全风险通告http://cn-sec.com/archives/2930155.html

发表评论

匿名网友 填写信息