【漏洞预警】Apache Struts远程代码执行漏洞(S2-059、CVE-2019-0230)

  • A+
所属分类:安全漏洞

2020年8月13日,飓风安全监测到Apache Struts 官方发布安全公告,披露 S2-059 Struts 远程代码执行漏洞。

【漏洞预警】Apache Struts远程代码执行漏洞(S2-059、CVE-2019-0230)

漏洞描述

Apache Struts2框架是一个用于开发Java EE网络应用程序的Web框架。Apache Struts于2020年8月13日披露 S2-059 Struts 远程代码执行漏洞(CVE-2019-0230),在使用某些tag等情况下可能存在OGNL表达式注入漏洞,从而造成远程代码执行,风险极大。提醒Apache Struts用户尽快采取安全措施阻止漏洞攻击。


影响版本

Apache Struts 2.0.0 - 2.5.20


安全版本

Apache Struts >= 2.5.22


安全建议

将Apache Struts框架升级至最新版本。


相关链接

https://cwiki.apache.org/confluence/display/WW/S2-059




我们会关注后续进展,请随时关注官方公告。


发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: