【漏洞通告】Apache Struts远程代码执行漏洞S2-062(CVE-2021-31805)

admin 2022年4月14日08:48:52安全漏洞评论167 views1260字阅读4分12秒阅读模式

通告编号:NS-2022-0012

2022-4-13
TAG:

Struts、S2-062、CVE-2021-31805

漏洞危害:

攻击者利用此漏洞,可实现远程代码执行。

版本 1.0

1

漏洞概述

2022年4月13日,绿盟科技CERT监测到Struts官方发布安全通告,修复了一个远程代码执行漏洞S2-062(CVE-2021-31805)。该漏洞为S2-061的修复不完全,当开发人员使用了 %{…} 语法进行强制OGNL解析时,仍有一些特殊的TAG属性可被二次解析;攻击者可构造恶意的OGNL表达式触发漏洞,从而实现远程代码执行。

Apache Struts是用于创建Java Web应用程序的开源框架,应用非常广泛。该漏洞已在Struts 2.5.30版本中修复,建议相关用户尽快升级版本进行防护。


参考链接:

https://cwiki.apache.org/confluence/display/WW/S2-062

SEE MORE →   

2影响范围

受影响版本

  • 2.0.0 <= Apache Struts <= 2.5.29


不受影响版本

  • Apache Struts >= 2.5.30


3漏洞检测

3.1 人工检测

使用maven打包的项目可通过pom.xml查看当前使用的struts2版本:

【漏洞通告】Apache Struts远程代码执行漏洞S2-062(CVE-2021-31805)

也可通过查看lib中的核心包查看struts版本:

【漏洞通告】Apache Struts远程代码执行漏洞S2-062(CVE-2021-31805)

若当前版本在受影响范围内,则可能存在安全风险。


4漏洞防护

4.1 官方升级

目前官方已发布新版本修复了此漏洞,请受影响的用户尽快更新进行防护,下载链接:https://struts.apache.org/download.cgi#struts-ga

4.2 其他防护措施

若相关用户暂时无法进行升级操作,可使用以下措施进行临时缓解:

将输入参数的值重新分配给某些Struts的标签属性时,始终对其进行验证,不要在值以外的标签属性中使用%{...} 语法引用用户可修改的输入。

开启ONGL表达式注入保护

参阅官方指南:

https://struts.apache.org/security/#proactively-protect-from-ognl-expression-injections-attacks-if-easily-applicable


END

【漏洞通告】Apache Struts远程代码执行漏洞S2-062(CVE-2021-31805)         
【漏洞通告】Apache Struts远程代码执行漏洞S2-062(CVE-2021-31805)        
声明

本安全公告仅用来描述可能存在的安全问题,绿盟科技不为此安全公告提供任何保证或承诺。由于传播、利用此安全公告所提供的信息而造成的任何直接或者间接的后果及损失,均由使用者本人负责,绿盟科技以及安全公告作者不为此承担任何责任。            

绿盟科技拥有对此安全公告的修改和解释权。如欲转载或传播此安全公告,必须保证此安全公告的完整性,包括版权声明等全部内容。未经绿盟科技允许,不得任意修改或者增减此安全公告内容,不得以任何方式将其用于商业目的。            

【漏洞通告】Apache Struts远程代码执行漏洞S2-062(CVE-2021-31805)

绿盟科技CERT 微信公众号
【漏洞通告】Apache Struts远程代码执行漏洞S2-062(CVE-2021-31805)
【漏洞通告】Apache Struts远程代码执行漏洞S2-062(CVE-2021-31805)
长按识别二维码,关注网络安全威胁信息


原文始发于微信公众号(绿盟科技CERT):【漏洞通告】Apache Struts远程代码执行漏洞S2-062(CVE-2021-31805)

特别标注: 本站(CN-SEC.COM)所有文章仅供技术研究,若将其信息做其他用途,由用户承担全部法律及连带责任,本站不承担任何法律及连带责任,请遵守中华人民共和国安全法.
  • 我的微信
  • 微信扫一扫
  • weinxin
  • 我的微信公众号
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2022年4月14日08:48:52
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                  【漏洞通告】Apache Struts远程代码执行漏洞S2-062(CVE-2021-31805) http://cn-sec.com/archives/907315.html

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: