【漏洞预警】Apache Airflow Docker Provider远程代码执行漏洞 (CVE-2022-38362)

admin 2022年8月18日08:01:18安全漏洞评论42 views607字阅读2分1秒阅读模式

基本信息   

风险等级: 高危                    

漏洞类型: 命令执行        

      

漏洞编号:            

CVE-2022-38362


漏洞描述    

近日,飓风安全应急团队监测到Apache发布安全公告,修复了一个存在于 Apache Airflow Docker Provider中的远程代码执行漏洞漏洞,Apache Airflow Docker Provider附带了一个样例DAG,该DAG很容易(经过验证)远程利用Airflow worker host上的代码。

【受影响版本】

  • AADP < 3.0.0

【安全版本】

  • 3.0.0 >= AADP

【漏洞预警】Apache Airflow Docker Provider远程代码执行漏洞 (CVE-2022-38362)

Apache Airflow是美国阿帕奇(Apache)基金会的一套用于创建、管理和监控工作流程的开源平台,具有可扩展和动态监控等特点。


影响范围        

AADP < 3.0.0


解决方案    

修复建议            

临时修复建议:

1.如果目前无法升级,若业务环境允许,使用白名单限制web端口的访问来降低风险。

2.关闭dag样例加载。


通用修复建议:

官方已发布安全版本,请及时下载更新,下载参考地址:

https://airflow.apache.org/docs/apache-airflow-providers-docker/stable/index.html


原文始发于微信公众号(飓风网络安全):【漏洞预警】Apache Airflow Docker Provider远程代码执行漏洞 (CVE-2022-38362)

特别标注: 本站(CN-SEC.COM)所有文章仅供技术研究,若将其信息做其他用途,由用户承担全部法律及连带责任,本站不承担任何法律及连带责任,请遵守中华人民共和国安全法.
  • 我的微信
  • 微信扫一扫
  • weinxin
  • 我的微信公众号
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2022年8月18日08:01:18
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                  【漏洞预警】Apache Airflow Docker Provider远程代码执行漏洞 (CVE-2022-38362) http://cn-sec.com/archives/1241054.html

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: