GitLab 远程代码执行漏洞安全风险通告

admin 2022年8月24日01:37:24安全漏洞评论6 views1074字阅读3分34秒阅读模式
GitLab 远程代码执行漏洞安全风险通告

奇安信CERT

致力于第一时间为企业级用户提供安全风险通告有效解决方案。




安全通告



近日,奇安信CERT监测到GitLab官方发布GitLab远程代码执行漏洞(CVE-2022-2884)通告,经过身份认证的远程攻击者可通过GitHub导入功能实现远程代码执行。鉴于此漏洞影响范围较大,建议客户尽快做好自查及防护。

漏洞名称

GitLab 远程代码执行漏洞

公开时间

2022-08-22

更新时间

2022-08-23

CVE编号

CVE-2022-2884

其他编号

QVD-2022-13846

威胁类型

代码执行

技术类型

数据验证不恰当

厂商

GitLab

产品

GitLab CE、GitLab EE

风险等级

奇安信CERT风险评级

风险等级

高危

蓝色(一般事件)

现时威胁状态

POC状态

EXP状态

在野利用状态

技术细节状态

未发现

未发现

未发现

未公开

漏洞描述

该漏洞存在是由于未对从GitHub中导入的API端点请求数据进行校验。经过身份认证的远程攻击者可通过发送特制的请求包最终在目标机器上执行任意代码。

影响版本

11.3.4 <=   GitLab CE/EE < 15.1.5
15.2 <= GitLab CE/EE < 15.2.3
15.3 <= GitLab CE/EE < 15.3.1

其他受影响组件



威胁评估

漏洞名称

GitLab 远程代码执行漏洞

CVE编号

CVE-2022-2884

其他编号

QVD-2022-13846

CVSS 3.1评级

高危

CVSS 3.1分数

9.9

CVSS向量

访问途径(AV

攻击复杂度(AC

网络

所需权限(PR

用户交互(UI

低权限

不需要

影响范围(S

机密性影响(C

改变

完整性影响(I

可用性影响(A

危害描述

经过身份认证的远程攻击者可通过GitHub导入功能实现远程代码执行。



处置建议

前官方已有可更新版本,建议受影响用户:

  • GitLab CE/EE 15.1.x及更低版本升级至15.1.5或更高版本;
  • GitLab CE/EE 15.2.x升级至15.2.3或更高版本;
  • GitLab CE/EE 15.3.x升级至15.3.1或更高版本。

https://about.gitlab.com/update/



参考资料

[1]https://about.gitlab.com/releases/2022/08/22/critical-security-release-gitlab-15-3-1-released/



时间线

2022年8月23日,安信 CERT发布安全风险通告


点击阅读原文

到奇安信NOX-安全监测平台查询更多漏洞详情

原文始发于微信公众号(奇安信 CERT):GitLab 远程代码执行漏洞安全风险通告

特别标注: 本站(CN-SEC.COM)所有文章仅供技术研究,若将其信息做其他用途,由用户承担全部法律及连带责任,本站不承担任何法律及连带责任,请遵守中华人民共和国安全法.
  • 我的微信
  • 微信扫一扫
  • weinxin
  • 我的微信公众号
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2022年8月24日01:37:24
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                  GitLab 远程代码执行漏洞安全风险通告 http://cn-sec.com/archives/1250978.html

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: