针对Linux普通用户一键提权root漏洞

admin 2023年1月17日19:40:07安全文章评论8 views358字阅读1分11秒阅读模式


CVE-2021-4034漏洞提权

前言:

    这里是基于pkexec,这是一个用于在Unix 操作系统中控制系统范围权限的组件。它为非特权进程与特权进程通信提供了一种有组织的方式。

通过这个组件的漏洞,在pkexec组件低于0.120版本中都受到影响。

在默认安装的UbuntuDebianFedoraCentOS上获得完整的root权限

需要测试的话我们需要先使用一个普通账号,这里我使用我centos7开始时候创建的普通账号

针对Linux普通用户一键提权root漏洞

然后我们直接使用poc,来利用

https://gitcode.net/mirrors/berdav/CVE-2021-4034

针对Linux普通用户一键提权root漏洞

然后我们直接用普通用户的权限运行就好

针对Linux普通用户一键提权root漏洞

这里就直接取得了root权限


针对Linux普通用户一键提权root漏洞




扫描二维码关注我们吧!




原文始发于微信公众号(白安全组):针对Linux普通用户一键提权root漏洞

特别标注: 本站(CN-SEC.COM)所有文章仅供技术研究,若将其信息做其他用途,由用户承担全部法律及连带责任,本站不承担任何法律及连带责任,请遵守中华人民共和国安全法.
  • 我的微信
  • 微信扫一扫
  • weinxin
  • 我的微信公众号
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2023年1月17日19:40:07
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                  针对Linux普通用户一键提权root漏洞 http://cn-sec.com/archives/1417549.html

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: