天融信关于DPDK多个高危漏洞风险提示

  • A+
所属分类:安全漏洞

【风险提示】天融信关于DPDK多个高危漏洞风险提示

0x00背景介绍



9月29日,天融信阿尔法实验室监测到DPDK 发布了DPDK vhost多个高危漏洞的风险通告,漏洞编号包含 CVE-2020-14374、CVE-2020-14375、CVE-2020-14376、CVE-2020-14377、CVE-2020-14378。

DPDK全称Intel Data Plane Development Kit,是intel提供的数据平面开发工具集,为Intel architecture(IA)处理器架构下用户空间高效的数据包处理提供库函数和驱动的支持。


0x01漏洞描述



CVE:CVE-2020-14374

Bugzilla: https://bugs.dpdk.org/show_bug.cgi?id=272

严重性:8.8(高)

简介:vhost_crypto中的远程代码执行。

攻击者可以利用该漏洞将任意数据复写至vhost_crypto应用程序中的任何地址,最终造成代码执行,虚拟环境逃逸。

 

CVE:CVE-2020-14375

Bugzilla: https://bugs.dpdk.org/show_bug.cgi?id=272

严重性:7.8(高)

简介:在vhost_crypto.c执行完相关功能验证后,攻击者在修改该内存区域内容,即可造成缓冲区溢出。

 

CVE:CVE-2020-14376

Bugzilla: https://bugs.dpdk.org/show_bug.cgi?id=272

严重性:7.8(高)

简介:vhost_crypto.c在从虚拟环境复制iv_data到客户端时存在缓冲区溢出。

 

CVE:CVE-2020-14377

Bugzilla: https://bugs.dpdk.org/show_bug.cgi?id=272

严重性:7.1(高)

简介:vhost_crypto.c中缺乏对cipher->para.dst_data_len的校验,虚拟环境中的攻击者通过控制该参数,可以造成缓冲区越界读取。

 

CVE:CVE-2020-14378

Bugzilla: https://bugs.dpdk.org/show_bug.cgi?id=272

严重性:3.3(低)

简介:vhost_crypto.c中move_desc函数存在一处整数溢出漏洞。虚拟环境中的攻击者通过触发该漏洞,可造成拒绝服务。


0x02漏洞编号



CVE-2020-14374

CVE-2020-14375

CVE-2020-14376

CVE-2020-14377

CVE-2020-14378


0x03漏洞等级



高危


0x04受影响版本



  • dpdk:<18.11.10

  • dpdk:<19.11.5

0x05修复建议



访问下方链接,下载并升级至 DPDK 最新版本

https://fast.dpdk.org/rel/dpdk-19.11.5.tar.xz

http://fast.dpdk.org/rel/dpdk-18.11.10.tar.xz

0x06支持热线



天融信公司后续将积极为用户提供技术支持,进行持续跟踪并及时通报进展,如有需要请拨打7 x 24小时客服联系电话:400-777-0777。


0x07声明



天融信阿尔法实验室拥有对此公告的修改和解释权,如欲转载,必须保证此公告的完整性。由于传播、利用此公告而造成的任何后果,均由使用者本人负责,天融信阿尔法实验室不为此承担任何责任。

天融信阿尔法实验室成立于2011年,一直以来,阿尔法实验室秉承“攻防一体”的理念,汇聚众多专业技术研究人员,从事攻防技术研究,在安全领域前瞻性技术研究方向上不断前行。作为天融信的安全产品和服务支撑团队,阿尔法实验室精湛的专业技术水平、丰富的排异经验,为天融信产品的研发和升级、承担国家重大安全项目和客户服务提供强有力的技术支撑。

天融信关于DPDK多个高危漏洞风险提示
【风险提示】天融信关于DPDK多个高危漏洞风险提示

天融信

阿尔法实验室

长按二维码关注我们


发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: