【漏洞通告】Apache Struts 2远程代码执行漏洞(CVE-2023-50164)

admin 2023年12月10日08:45:51评论28 views字数 810阅读2分42秒阅读模式

一、漏洞概述

CVE   ID

CVE-2023-50164

发现时间

2023-12-07

类    型

RCE

等    级

高危

攻击向量

网络

所需权限

攻击复杂度

用户交互

PoC/EXP

未知

在野利用

未知

Apache Struts 2是一个基于MVC设计模式的Web应用框架,可用于创建企业级Java web应用程序。
12月7日,启明星辰VSRC监测到Apache Struts 2中修复了一个远程代码执行漏洞(CVE-2023-50164)。
Apache Struts 2多个受影响版本中,由于文件上传逻辑存在缺陷,威胁者可操纵文件上传参数来实现路径遍历,某些情况下可能导致上传恶意文件,造成远程代码执行。

二、影响范围

Apache Struts 2.5.0 - 2.5.32
Apache Struts 6.0.0 - 6.3.0

三、安全措施

3.1 升级版本

目前该漏洞已经修复,受影响用户可升级到Apache Struts 2.5.33、6.3.0.2 或更高版本。
下载链接:
https://struts.apache.org/download.cgi

3.2 临时措施

暂无。

3.3 通用建议

定期更新系统补丁,减少系统漏洞,提升服务器的安全性。
加强系统和网络的访问控制,修改防火墙策略,关闭非必要的应用端口或服务,减少将危险服务(如SSH、RDP等)暴露到公网,减少攻击面。
使用企业级安全产品,提升企业的网络安全性能。
加强系统用户和权限管理,启用多因素认证机制和最小权限原则,用户和软件权限应保持在最低限度。
启用强密码策略并设置为定期修改。

3.4 参考链接

https://cwiki.apache.org/confluence/display/WW/S2-066
https://nvd.nist.gov/vuln/detail/CVE-2023-50164



原文始发于微信公众号(启明星辰安全简讯):【漏洞通告】Apache Struts 2远程代码执行漏洞(CVE-2023-50164)

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2023年12月10日08:45:51
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   【漏洞通告】Apache Struts 2远程代码执行漏洞(CVE-2023-50164)http://cn-sec.com/archives/2282215.html

发表评论

匿名网友 填写信息