CVE-2021-3156漏洞复现

  • A+
所属分类:安全文章


CVE-2021-3156漏洞介绍

Sudo是一个功能强大的工具,其允许普通用户执行root权限命令,大多数基于Unix和Linux的操作系统都包含sudo

2021年01月26日,sudo被披露存在一个基于堆的缓冲区溢出漏洞(CVE-2021-3156,该漏洞被命名为“Baron Samedit”),可导致本地权限提升。

当在类Unix的操作系统上执行命令时,非root用户可以使用sudo命令来以root用户身份执行命令。由于sudo错误地在参数中转义了反斜杠导致堆缓冲区溢出,从而允许任何本地用户(无论是否在sudoers文件中)获得root权限,无需进行身份验证,且攻击者不需要知道用户密码。

安全研究人员于1月26日公开披露了此漏洞,并表示该漏洞已经隐藏了近十年。

受影响版本

Sudo 1.8.2 - 1.8.31p2

Sudo 1.9.0 - 1.9.5p1

不受影响版本

Sudo =>1.9.5p2
复现环境

ubuntu 20.04 LTS

CVE-2021-3156漏洞复现


复现结果

文章来源:https://www.kalmarunionen.dk/writeups/sudo/

poc来源:https://haxx.in/CVE-2021-3156_nss_poc_ubuntu.tar.gz


CVE-2021-3156漏洞复现

漏洞检测

用户可以使用非root的账户登录系统,运行“ sudoedit -s / ”命令,

若返回如图以“ sudoedit:”开头的错误,则当前系统可能存在安全风险。

不受影响的系统将显示以“ usage:”开头的错误响应。

CVE-2021-3156漏洞复现

漏洞防护

目前官方已在sudo新版本1.9.5p2中修复了该漏洞,请受影响的用户尽快升级版本进行防护,官方下载链接:

https://www.sudo.ws/download.html


本文始发于微信公众号(连接世界的暗影):CVE-2021-3156漏洞复现

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: