Apache Shiro < 1.7.1 权限绕过漏洞(CVE-2020-17523)

  • A+
所属分类:安全漏洞



阿里云安全风险提示


Apache shiro < 1.7.1权限绕过漏洞

(CVE-2020-17523)


Apache Shiro < 1.7.1 权限绕过漏洞(CVE-2020-17523)



Apache Shiro是一个应用广泛的权限管理的用户认证与授权框架。2021年2月1日,Apache Shiro发布1.7.1版本,修复了 Apache Shiro 身份验证绕过漏洞 (CVE-2020-17523)。攻击者可以使用包含payload的恶意请求绕过Shiro的身份认证。漏洞利用需要配合Spring环境,风险评定中危。阿里云应急响应中心提醒Apache Shiro用户尽快采取安全措施阻止漏洞攻击。


Apache Shiro < 1.7.1 权限绕过漏洞(CVE-2020-17523)



漏洞描述


Apache Shiro是一个应用广泛的权限管理的用户认证与授权框架。2021年2月1日,Apache Shiro发布1.7.1版本,修复了 Apache Shiro 身份验证绕过漏洞 (CVE-2020-17523)。

攻击者可以使用包含payload的恶意请求绕过Shiro的身份认证。漏洞利用需要配合Spring环境,风险评定中危。


阿里云应急响应中心提醒Apache Shiro用户尽快采取安全措施阻止漏洞攻击。


时间轴


2020/02/01


Apache Shiro官方发布安全更新。


2020/02/01


阿里云安全发布漏洞风险提示。



漏洞评分

CVE-2020-17523 中危,需结合Spring使用环境。


影响版本 

Apache Shiro < 1.7.1


安全版本

Apache Shiro >= 1.7.1

相关链接

https://github.com/apache/shiro/releases/tag/shiro-root-1.7.1


https://shiro.apache.org/news.html


Apache Shiro < 1.7.1 权限绕过漏洞(CVE-2020-17523)



【漏洞预警】Apache Shiro < 1.7.1 权限绕过漏洞(CVE-2020-17523)


关注我们

第一时间获知风险

阿里云安全应急响应中心





本文始发于微信公众号(阿里云先知):【漏洞预警】Apache Shiro < 1.7.1 权限绕过漏洞(CVE-2020-17523)

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: