Apache CloudStack代码执行漏洞(CVE-2024-38346)

admin 2024年7月9日08:20:50评论60 views字数 1407阅读4分41秒阅读模式
一、漏洞概述
漏洞名称
Apache CloudStack代码执行漏洞
CVE   ID
CVE-2024-38346
漏洞类型
代码注入
发现时间
2024-07-08
漏洞评分
9.8
漏洞等级
高危
攻击向量
网络
所需权限
利用难度
用户交互
PoC/EXP
未公开
在野利用
未发现

Apache CloudStack是一个开源的云计算平台,旨在为用户提供功能强大的云计算环境,涵盖计算、存储、网络等资源的管理和服务。

2024年7月8日,启明星辰集团VSRC监测到Apache CloudStack中修复两个代码执行漏洞,威胁者可利用这些漏洞获取敏感信息、执行任意代码或破坏CloudStack 管理基础设施。

CVE-2024-38346:Apache CloudStack代码执行漏洞

Apache CloudStack中存在注入漏洞,由于Apache CloudStack集群服务在未经身份验证的端口(默认9090)上运行,威胁者可通过该端口访问集群服务并利用该漏洞在目标hypervisors和CloudStack管理服务器主机上执行任意命令或代码。

CVE-2024-39864:Apache CloudStack集成API服务代码执行漏洞

Apache CloudStack集成API服务提供了未经身份验证的API Server端口(启用时通常为8096),该端口允许浏览器或CLI客户端直接连接到管理服务器而无需进行身份验证。默认情况下,集成 API 服务端口为禁用(integration.api.port 设置为0或负数),由于初始化逻辑不当,当集成 API 服务的端口值设置为 0(默认值)时,它会在随机端口上侦听,可以访问CloudStack 管理网络的威胁者可以扫描并找到随机集成 API 服务端口,利用它执行未经授权的管理操作并在 CloudStack 管理主机上导致远程代码执行。

二、影响范围

Apache CloudStack 4.0.0 - 4.18.2.0

Apache CloudStack 4.19.0.0 - 4.19.0.1

三、安全措施

3.1 升级版本

目前该漏洞已经修复,受影响用户可升级到Apache CloudStack 4.18.2.1、4.19.0.2 或更高版本。

下载链接:

https://github.com/apache/cloudstack/releases

3.2 临时措施

限制网络访问:将集群服务端口(默认 9090)和其他必要端口的访问限制为仅允许受信任的主机或设备访问。

3.3 通用建议

定期更新系统补丁,减少系统漏洞,提升服务器的安全性。

加强系统和网络的访问控制,修改防火墙策略,关闭非必要的应用端口或服务,减少将危险服务(如SSH、RDP等)暴露到公网,减少攻击面。

使用企业级安全产品,提升企业的网络安全性能。

加强系统用户和权限管理,启用多因素认证机制和最小权限原则,用户和软件权限应保持在最低限度。

启用强密码策略并设置为定期修改。

3.4 参考链接

https://lists.apache.org/thread/6l51r00csrct61plkyd3qg3fj99215d1

https://cloudstack.apache.org/blog/security-release-advisory-4.19.0.2-4.18.2.1/

原文始发于微信公众号(启明星辰安全简讯):【漏洞通告】Apache CloudStack代码执行漏洞(CVE-2024-38346)

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2024年7月9日08:20:50
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   Apache CloudStack代码执行漏洞(CVE-2024-38346)http://cn-sec.com/archives/2932050.html

发表评论

匿名网友 填写信息