【漏洞通告】Apache Druid 文件读取漏洞 CVE-2021-26920

  • A+
所属分类:安全漏洞

漏洞名称 Apache Druid 文件读取漏洞

组件名称 : Apache Druid

影响范围 Apache Druid < 0.21.0

漏洞类型 文件读取

利用条件 :

1、用户认证:否

2、触发方式:远程

综合评价 :

<综合评定利用难度>:容易,无需授权即可文件读取。

<综合评定威胁等级>:低危,能造成敏感信息泄露。


漏洞分析


组件介绍

    Apache Druid 是一个分布式的、支持实时多维 OLAP 分析的数据处理系统。它既支持高速的数据实时摄入处理,也支持实时且灵活的多维数据分析查询。因此 Druid 最常用的场景就是大数据背景下、灵活快速的多维 OLAP 分析。Druid 还支持根据时间戳对数据进行预聚合摄入和聚合分析,因此也有用户经常在有时序数据处理分析的场景中使用。


2 漏洞描述

   近日,深信服安全团队监测到一则Apache Druid组件存在文件读取漏洞的信息,漏洞编号:CVE-2021-29620,漏洞威胁等级:低危。

   该漏洞是由于用户指定 HTTP InputSource 没有做出限制,可以通过将文件 URL 传递给 HTTP InputSource 来绕过应用程序级别的限制。攻击者可利用该漏洞在未授权情况下,构造恶意请求执行文件读取,最终造成服务器敏感性信息泄露。


漏洞复现


搭建Apache Druid组件0.20.1版本环境,复现该漏洞,效果如下:

【漏洞通告】Apache Druid 文件读取漏洞 CVE-2021-26920


影响范围


    可能受漏洞影响的资产广泛分布于世界各地,主要集中在美国、中国、印度等国家,国内主要集中在浙江、北京等地。

    目前受影响的Apache Druid版本:


Apache Druid < 0.21.0


解决方案


1 如何检测组件系统版本

打开网站控制台首页,然后在Status中即可查看组件版本

【漏洞通告】Apache Druid 文件读取漏洞 CVE-2021-26920


2 官方修复建议

用户可以通过升级到 0.21.0 或更高版本来避免该问题。下载链接如下:

 https://druid.apache.org/downloads.html


3 深信服解决方案

深信服下一代防火墙】可防御此漏洞, 建议用户将深信服下一代防火墙开启 IPS 防护策略,并更新最新安全防护规则,即可轻松抵御此高危风险。

深信服安全感知平台】结合云端实时热点高危/紧急漏洞信息,可快速检出业务场景下的该漏洞,并可联动【深信服下一代防火墙等产品】实现对攻击者IP的封堵。

深信服安全云眼】预计2021年7月7日,完成检测更新,对所有用户网站探测,保障用户安全。不清楚自身业务是否存在漏洞的用户,可注册信服云眼账号,获取30天免费安全体验。

注册地址:http://saas.sangfor.com.cn

深信服云镜】预计2021年7月7日,完成检测能力的发布,部署了云镜的用户可以通过升级来快速检测网络中是否受该高危风险影响,避免被攻击者利用。离线使用云镜的用户需要下载离线更新包来获得漏洞检测能力,可以连接云端升级的用户可自动获得漏洞检测能力。


时间轴


2021/7/2  深信服监测到Apache Druid文件读取漏洞攻击信息。 

2021/7/5  深信服千里目安全实验室分析并复现此漏洞,并发布漏洞通告和深信服产品解决方案。


点击阅读原文,及时关注并登录深信服智安全平台,可轻松查询漏洞相关解决方案。

【漏洞通告】Apache Druid 文件读取漏洞 CVE-2021-26920


深信服千里目安全实验室

【漏洞通告】Apache Druid 文件读取漏洞 CVE-2021-26920

深信服科技旗下安全实验室,致力于网络安全攻防技术的研究和积累,深度洞察未知网络安全威胁,解读前沿安全技术。

● 扫码关注我们



本文始发于微信公众号(深信服千里目安全实验室):【漏洞通告】Apache Druid 文件读取漏洞 CVE-2021-26920

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: