【风险提示】天融信关于WebLogic多个高危漏洞风险提示

  • A+
所属分类:安全漏洞

【风险提示】天融信关于WebLogic多个高危漏洞风险提示

0x00背景介绍



7月21日,天融信阿尔法实验室监测到Oracle官方发布了2021年7月关键补丁更新,此次更新修复漏洞共342个,其中包括严重漏洞50个、高危45个、中危107个、低危140个。


0x01漏洞描述


    此次更新中修复了多个WebLogic组件的漏洞,包括多个严重的漏洞,这些漏洞允许未经身份验证的攻击者通过IIOP或者T3协议发送构造好的恶意请求,从而在Oracle WebLogic Server执行代码这次安全更新修复的以下漏洞值得重点关注。

  • CVE-2021-2394:任意执行代码漏洞

    未经身份验证的攻击者通过T3或IIOP协议发送恶意请求,最终接管服务器,评分9.8。

  • CVE-2021-2397:任意执行代码漏洞

    未经身份验证的攻击者通过T3或IIOP协议发送恶意请求,最终接管服务器,评分9.8

  • CVE-2021-2382:任意执行代码漏洞

    未经身份验证的攻击者通过T3或IIOP协议发送恶意请求,最终接管服务器,评分9.8。


编号

组件

协议

CVSS

需要用户认证

受影响版本

CVE-2021-2394

Oracle WebLogic Server(Core)

T3, IIOP

9.8

10.3.6.0.0, 12.1.3.0.0,  12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0

CVE-2021-2397

Oracle WebLogic Server(Core)

T3, IIOP

9.8

10.3.6.0.0, 12.1.3.0.0,  12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0

CVE-2021-2382

Oracle WebLogic Server(Security)

T3, IIOP

9.8

10.3.6.0.0, 12.1.3.0.0,  12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0

CVE-2021-2428

Oracle Coherence(Core)

T3, IIOP

8.1

12.1.3.0.0, 12.2.1.3.0,  12.2.1.4.0, 14.1.1.0.0

CVE-2021-2371

Oracle Coherence(Core)

T3, IIOP

7.5

3.7.1.0, 12.1.3.0.0,  12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0

CVE-2021-2344

Oracle Coherence(Core)

T3, IIOP

7.5

3.7.1.0, 12.1.3.0.0,  12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0

CVE-2021-2378

Oracle WebLogic Server(Core)

T3, IIOP

7.5

10.3.6.0.0, 12.1.3.0.0,  12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0

CVE-2021-2376

Oracle WebLogic Server(Web  Services)

T3, IIOP

7.5

10.3.6.0.0, 12.1.3.0.0,  12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0

CVE-2021-2403

Oracle WebLogic Server(Core)

HTTP

5.3

10.3.6.0.0, 12.1.3.0.0,  12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0




0x02漏洞编号



  • CVE-2021-2394

  • CVE-2021-2397

  • CVE-2021-2382

  • CVE-2021-2428

  • CVE-2021-2371

  • CVE-2021-2344

  • CVE-2021-2378

  • CVE-2021-2376

  • CVE-2021-2403


0x03漏洞等级



    高危


0x04修复建议



  • 受影响版本:


编号

受影响版本

CVE-2021-2394

10.3.6.0.0, 12.1.3.0.0,  12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0

CVE-2021-2397

10.3.6.0.0, 12.1.3.0.0,  12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0

CVE-2021-2382

10.3.6.0.0, 12.1.3.0.0,  12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0

CVE-2021-2428

12.1.3.0.0, 12.2.1.3.0,  12.2.1.4.0, 14.1.1.0.0

CVE-2021-2371

3.7.1.0, 12.1.3.0.0,  12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0

CVE-2021-2344

3.7.1.0, 12.1.3.0.0,  12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0

CVE-2021-2378

10.3.6.0.0, 12.1.3.0.0,  12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0

CVE-2021-2376

10.3.6.0.0, 12.1.3.0.0,  12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0

CVE-2021-2403

10.3.6.0.0, 12.1.3.0.0,  12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0

  • 修复建议:

Oracle已经发布了安全更新,建议受影响用户尽快更新:

https://www.oracle.com/security-alerts/cpujul2021.html


0x05支持热线



天融信公司后续将积极为用户提供技术支持,进行持续跟踪并及时通报进展,如有需要请拨打7 x 24小时客服联系电话:400-777-0777。


0x06声明



天融信阿尔法实验室拥有对此公告的修改和解释权,如欲转载,必须保证此公告的完整性。由于传播、利用此公告而造成的任何后果,均由使用者本人负责,天融信阿尔法实验室不为此承担任何责任。


天融信阿尔法实验室成立于2011年,一直以来,阿尔法实验室秉承“攻防一体”的理念,汇聚众多专业技术研究人员,从事攻防技术研究,在安全领域前瞻性技术研究方向上不断前行。作为天融信的安全产品和服务支撑团队,阿尔法实验室精湛的专业技术水平、丰富的排异经验,为天融信产品的研发和升级、承担国家重大安全项目和客户服务提供强有力的技术支撑。

【风险提示】天融信关于WebLogic多个高危漏洞风险提示
【风险提示】天融信关于WebLogic多个高危漏洞风险提示

天融信

阿尔法实验室

长按二维码关注我们



本文始发于微信公众号(天融信阿尔法实验室):【风险提示】天融信关于WebLogic多个高危漏洞风险提示

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: