Atlassian Confluence远程代码执行漏洞风险提示

  • A+
所属分类:安全漏洞
Atlassian Confluence远程代码执行漏洞风险提示


漏洞公告

近日,安恒信息应急响应中心监测到Atlassian发布安全公告,修复了一处Atlassian Confluence的远程代码执行漏洞(CVE-2021-26084),未授权攻击者通过构造恶意请求注入OGNL表达式,从而在目标服务上执行任意代码。目前,相关漏洞细节和攻击代码已经流出,攻击者无需身份验证即可利用该漏洞入侵目标服务器,建议使用Atlassian Confluence的用户尽快采取措施。


官方公告链接:

https://confluence.atlassian.com/doc/confluence-security-advisory-2021-08-25-1077906215.html



影响范围


影响版本:

Atlassian Confluence Server/Data Center < 6.13.23

Atlassian Confluence Server/Data Center < 7.4.11

Atlassian Confluence Server/Data Center < 7.11.6

Atlassian Confluence Server/Data Center < 7.12.5

Atlassian Confluence Server/Data Center < 7.13.0


通过安恒SUMAP平台对全球部署的Atlassian Confluence进行统计,最新查询分布情况如下:


全球分布:

Atlassian Confluence远程代码执行漏洞风险提示

国内分布:

Atlassian Confluence远程代码执行漏洞风险提示

安恒应急响应中心已验证该漏洞的可利用性:

Atlassian Confluence远程代码执行漏洞风险提示



漏洞描述


Atlassian Confluence是Atlassian公司出品的专业的企业知识管理与协同软件,可用于构建企业文库等。根据分析Atlassian Confluence存在一个OGNL表达式注入漏洞,该漏洞允许未经身份验证的攻击者构造恶意请求注入OGNL表达式,从而在服务器上执行任意代码,可导致服务器被攻击者控制。




缓解措施


紧急:目前漏洞细节和利用代码已经公开,建议使用Atlassian Confluence的用户及时测试并升级到漏洞修复的版本。


处置建议:升级Atlassian Confluence至安全版本


临时缓解措施:如果无法升级可执行官方提供的临时缓解脚本。


Linux:

https://confluence.atlassian.com/doc/files/1077906215/1077916296/2/1629936383093/cve-2021-26084-update.sh

执行前需要关闭Confluence,并修改cve-2021-26084-update.sh文件并设置INSTALLATION_DIRECTORY为您的 Confluence 安装目录


Windows:

https://confluence.atlassian.com/doc/files/1077906215/1077916298/2/1629936382985/cve-2021-26084-update.ps1

执行前需要关闭Confluence,并修改cve-2021-26084-update.ps1文件并设置INSTALLATION_DIRECTORY为您的 Confluence 安装目录


安恒应急响应中心

2021年09月










本文始发于微信公众号(安恒信息应急响应中心):Atlassian Confluence远程代码执行漏洞风险提示

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: