【最新漏洞预警】CVE-2022-29464 WSO2 API Manager远程命令执行漏洞

admin 2022年4月21日12:39:37安全漏洞评论260 views1223字阅读4分4秒阅读模式
漏洞信息


WSO2 API Manager是WSO2公司的一套API生命周期管理解决方案。最近发现CNNVD爆出了WSO2 API Manager存在安全漏洞:


【最新漏洞预警】CVE-2022-29464 WSO2 API Manager远程命令执行漏洞


漏洞编号CVE-2022-29464。从漏洞描述来看,由于对文件上传接口缺少严格检查,导致存在任意文件上传漏洞,可直接GetShell。影响版本:


  • WSO2 API Manager 2.2.0 and above

  • WSO2 Identity Server 5.2.0 and above

  • WSO2 Identity Server Analytics 5.4.0, 5.4.1, 5.5.0, 5.6.0

  • WSO2 Identity Server as Key Manager 5.3.0 and above

  • WSO2 Enterprise Integrator 6.2.0 and above

漏洞分析


本地搭建环境,启动:


【最新漏洞预警】CVE-2022-29464 WSO2 API Manager远程命令执行漏洞


这是一个文件上传漏洞,首先搜索涉及文件上传处理的接口。WSO2 API Manager默认开启了多个接口,在对`carbon`进行抓包分析的过程中,发现文件上传数据包:


【最新漏洞预警】CVE-2022-29464 WSO2 API Manager远程命令执行漏洞


查看接口配置:


【最新漏洞预警】CVE-2022-29464 WSO2 API Manager远程命令执行漏洞


从配置来看,访问接口不需要认证。查看URL映射配置文件:


【最新漏洞预警】CVE-2022-29464 WSO2 API Manager远程命令执行漏洞


找到多个和文件上传有关的映射:


org.wso2.carbon.ui.transports.fileupload.AnyFileUploadExecutororg.wso2.carbon.ui.transports.fileupload.JarZipUploadExecutororg.wso2.carbon.ui.transports.fileupload.DBSFileUploadExecutororg.wso2.carbon.ui.transports.fileupload.ToolsFileUploadExecutororg.wso2.carbon.ui.transports.fileupload.ToolsAnyFileUploadExecutor


上面的类都继承于`AbstractFileUploadExecutor`。定义了函数`execute`对上传文件进行处理,子类对该函数进行了重写。以其中的`ToolsAnyFileUploadExecutor`为例:


【最新漏洞预警】CVE-2022-29464 WSO2 API Manager远程命令执行漏洞


没有对表单名称进行任何处理,直接进行路径拼接,存在路径穿越的隐患。构造请求进行调试:


【最新漏洞预警】CVE-2022-29464 WSO2 API Manager远程命令执行漏洞


同时上传文件名和文件内容也可控,可通过构造特定请求,直接写入webshell:


【最新漏洞预警】CVE-2022-29464 WSO2 API Manager远程命令执行漏洞


【最新漏洞预警】CVE-2022-29464 WSO2 API Manager远程命令执行漏洞


修复方式


通过补丁对比,发现新版本将`AbstractFileUploadExecutor`子类的函数`execute`弃用,直接返回`false`,比如`ToolsAnyFileUploadExecutor`:


【最新漏洞预警】CVE-2022-29464 WSO2 API Manager远程命令执行漏洞



由于传播、利用此文档提供的信息而造成任何直接或间接的后果及损害,均由使用本人负责,且听安全团队及文章作者不为此承担任何责任。


【最新漏洞预警】CVE-2022-29464 WSO2 API Manager远程命令执行漏洞



点关注,不迷路!

【最新漏洞预警】CVE-2022-29464 WSO2 API Manager远程命令执行漏洞

原文始发于微信公众号(且听安全):【最新漏洞预警】CVE-2022-29464 WSO2 API Manager远程命令执行漏洞

特别标注: 本站(CN-SEC.COM)所有文章仅供技术研究,若将其信息做其他用途,由用户承担全部法律及连带责任,本站不承担任何法律及连带责任,请遵守中华人民共和国安全法.
  • 我的微信
  • 微信扫一扫
  • weinxin
  • 我的微信公众号
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2022年4月21日12:39:37
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                  【最新漏洞预警】CVE-2022-29464 WSO2 API Manager远程命令执行漏洞 http://cn-sec.com/archives/931506.html

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: