【漏洞预警】Tensorflow拒绝服务漏洞(CVE-2022-23569)

admin 2022年4月27日01:02:27安全漏洞评论21 views746字阅读2分29秒阅读模式

 01



漏洞描述





ensorFlow由谷歌人工智能团队谷歌大脑(Google Brain)开发和维护,拥有包括TensorFlow Hub、TensorFlow Lite、TensorFlow Research Cloud在内的多个项目以及各类应用程序接口(Application Programming Interface, API)。自2015年11月9日起,TensorFlow依据阿帕奇授权协议(Apache 2.0 open source license)开放源代码。
TensorFlow中的多个操作可用于通过CHECK-fails 触发拒绝服务(即断言失败)。这类似于TFSA-2021-198( CVE-2021-41197 ) 并具有类似的修复程序。TensorFlow 允许张量具有大量维度,并且每个维度可以任意大。但是,张量中的元素总数必须在int64_t. 如果发生溢出,MultiplyWithoutOverflow将返回否定结果。在大多数 TensorFlow 代码库中,这会导致CHECK-failure存在较新的构造,它们返回aStatus而不是使二进制文件崩溃。  

 02

漏洞危害



TensorFlow存在拒绝访问漏洞,攻击者可利用该漏洞对目标发起拒绝服务攻击。

 03

影响范围




Google TensorFlow <2.8.0


04

漏洞等级

   

   中危


 05

修复方案


厂商已发布了漏洞修复程序,请及时关注更新:
https://github.com/tensorflow/tensorflow/security/advisories/GHSA-qj5r-f9mv-rffh














END

长按识别二维码,了解更多


【漏洞预警】Tensorflow拒绝服务漏洞(CVE-2022-23569)


原文始发于微信公众号(易东安全研究院):【漏洞预警】Tensorflow拒绝服务漏洞(CVE-2022-23569)

特别标注: 本站(CN-SEC.COM)所有文章仅供技术研究,若将其信息做其他用途,由用户承担全部法律及连带责任,本站不承担任何法律及连带责任,请遵守中华人民共和国安全法.
  • 我的微信
  • 微信扫一扫
  • weinxin
  • 我的微信公众号
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2022年4月27日01:02:27
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                  【漏洞预警】Tensorflow拒绝服务漏洞(CVE-2022-23569) http://cn-sec.com/archives/949243.html

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: