【漏洞通告】Apache APISIX JWT-Auth Plugin 密钥泄露漏洞 CVE-2022-29266

admin 2022年4月30日13:06:08安全漏洞评论13 views937字阅读3分7秒阅读模式

漏洞名称

Apache APISIX JWT-Auth Plugin密钥泄露漏洞

组件名称

Apache APISIX

影响范围

Apache APISIX < 2.13.1

漏洞类型

信息泄露

利用条件

1、用户认证:不需要用户认证

2、前置条件:开启 jwt-auth plugin

3、触发方式:远程

综合评价

<综合评定利用难度>:未知。

<综合评定威胁等级>:高危,能获取用户密钥信息。


漏洞分析


组件介绍

Apache APISIX 是 Apache 基金会推出的一款 API 网关管理工具,具有实时、高效的特点,借助它可以非常方便的对 API 进行验证和鉴权并进行监控。


2 漏洞描述

近日,深信服安全团队监测到一则 Apache APISIX 的 JWT-Auth Plugin 存在密钥泄露漏洞的信息,漏洞编号:CVE-2022-29266,漏洞威胁等级:高危。


该漏洞是由于 JWT-Auth Plugin 在接受到一个恶意构造的请求后会返回用户的密钥信息连同错误信息一起返回,攻击者可利用该漏洞获取用户的密钥信息。


影响范围


目前受影响的 Apache APISIX 版本:

Apache APISIX < 2.13.1


解决方案


如何检测组件系统版本

访问 APISIX 服务后台,执行以下命令即可查看版本。

apisix version

【漏洞通告】Apache APISIX JWT-Auth Plugin 密钥泄露漏洞 CVE-2022-29266



官方修复建议

当前官方已发布最新版本,建议受影响的用户及时更新升级到最新版本。链接如下:

https://apisix.apache.org/


参考链接


https://lists.apache.org/thread/6qpfyxogbvn18g9xr8g218jjfjbfsbhr


时间轴


2022/4/29  深信服监测到 Apache APISIX JWT-Auth Plugin 密钥泄露漏洞信息。

2022/4/29 深信服千里目安全实验室发布漏洞通告。



点击阅读原文,及时关注并登录深信服智安全平台,可轻松查询漏洞相关解决方案。

【漏洞通告】Apache APISIX JWT-Auth Plugin 密钥泄露漏洞 CVE-2022-29266


深信服千里目安全实验室

【漏洞通告】Apache APISIX JWT-Auth Plugin 密钥泄露漏洞 CVE-2022-29266

深信服科技旗下安全实验室,致力于网络安全攻防技术的研究和积累,深度洞察未知网络安全威胁,解读前沿安全技术。

● 扫码关注我们




原文始发于微信公众号(深信服千里目安全实验室):【漏洞通告】Apache APISIX JWT-Auth Plugin 密钥泄露漏洞 CVE-2022-29266

特别标注: 本站(CN-SEC.COM)所有文章仅供技术研究,若将其信息做其他用途,由用户承担全部法律及连带责任,本站不承担任何法律及连带责任,请遵守中华人民共和国安全法.
  • 我的微信
  • 微信扫一扫
  • weinxin
  • 我的微信公众号
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2022年4月30日13:06:08
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                  【漏洞通告】Apache APISIX JWT-Auth Plugin 密钥泄露漏洞 CVE-2022-29266 http://cn-sec.com/archives/965239.html

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: