【漏洞通告】Apache Tomcat 拒绝服务漏洞CVE-2022-29885

admin 2022年7月2日15:26:12安全漏洞评论692 views1433字阅读4分46秒阅读模式
【漏洞通告】Apache Tomcat 拒绝服务漏洞CVE-2022-29885

漏洞名称:

Apache Tomcat 拒绝服务漏洞

组件名称:

Apache Tomcat

影响范围:

未配置 EncryptInterceptor 则全版本受影响

配置 EncryptInterceptor 如下版本受影响:

10.1.0-M1 ≤ Apache Tomcat ≤ 10.1.0-M14

10.0.0-M1 ≤ Apache Tomcat ≤10.0.20

9.0.13 ≤ Apache Tomcat ≤ 9.0.62

8.5.38 ≤Apache Tomcat ≤8.5.78

漏洞类型:

拒绝服务

利用条件:

1、用户认证:不需要用户认证
2、前置条件:
开启集群配置

3、触发方式:远程

综合评价:

<综合评定利用难度>:未知。

<综合评定威胁等级>:中危,能造成拒绝服务。



漏洞分析

【漏洞通告】Apache Tomcat 拒绝服务漏洞CVE-2022-29885

组件介绍

Apache Tomcat 是美国阿帕奇(Apache)软件基金会的一款轻量级 Web 应用服务器,该程序实现了对Servlet 和 JavaServer Page(JSP) 的支持。

【漏洞通告】Apache Tomcat 拒绝服务漏洞CVE-2022-29885

漏洞简介

2022年7月2日,深信服安全团队监测到一则 Apache Tomcat 拒绝服务漏洞的信息,漏洞编号:CVE-2022-29885,漏洞威胁等级:中危。


该漏洞是由于 Tomcat 开启集群配置中存在缺陷,攻击者可利用该漏洞在未权限的情况下,构造恶意数据造成拒绝服务,最终导致目标服务器拒绝服务。

影响范围

目前受影响的 Apache Tomcat 版本:

未配置EncryptInterceptor则全版本受影响

配置EncryptInterceptor如下版本受影响:

10.1.0-M1 ≤ Apache Tomcat ≤ 10.1.0-M14

10.0.0-M1 ≤ Apache Tomcat ≤10.0.20

9.0.13 ≤ Apache Tomcat ≤ 9.0.62

8.5.38 ≤ Apache Tomcat ≤8.5.78

解决方案

【漏洞通告】Apache Tomcat 拒绝服务漏洞CVE-2022-29885

1.如何检测组件系统版本

Windows 系统

在 Tomcat 的 bin 目录下,输入 catalina version 命令即可显示版本信息。


Linux 系统

在 bin 目录下执行如下命令:sh version.sh  可显示版本信息。

【漏洞通告】Apache Tomcat 拒绝服务漏洞CVE-2022-29885
【漏洞通告】Apache Tomcat 拒绝服务漏洞CVE-2022-29885

2.官方修复建议

当前官方已发布最新版本,建议受影响的用户及时更新升级到最新版本。链接如下:

https://tomcat.apache.org/security-10.html

https://tomcat.apache.org/security-9.html

https://tomcat.apache.org/security-8.html

【漏洞通告】Apache Tomcat 拒绝服务漏洞CVE-2022-29885

3.深信服解决方案

3.1 主动检测

支持对 Apache Tomcat 拒绝服务漏洞(CVE-2022-29885)的主动检测,可批量快速检出业务场景中该事件的受影响资产情况,相关产品如下:

【深信服安全云眼CloudEye】已发布检测方案。

【深信服云镜YJ】已发布检测方案。

【深信服漏洞评估工具TSS】 已发布检测方案。

【深信服安全托管服务MSS】已发布检测方案。


时间轴


2022/7/1

深信服监测到 Apache Tomcat 拒绝服务漏洞信息。

2022/7/2 

深信服千里目安全技术中心发布漏洞通告。

参考链接


https://lists.apache.org/thread/2b4qmhbcyqvc7dyfpjyx54c03x65vhcv


点击阅读原文,及时关注并登录深信服智安全平台,可轻松查询漏洞相关解决方案。

【漏洞通告】Apache Tomcat 拒绝服务漏洞CVE-2022-29885
【漏洞通告】Apache Tomcat 拒绝服务漏洞CVE-2022-29885



原文始发于微信公众号(深信服千里目安全实验室):【漏洞通告】Apache Tomcat 拒绝服务漏洞CVE-2022-29885

特别标注: 本站(CN-SEC.COM)所有文章仅供技术研究,若将其信息做其他用途,由用户承担全部法律及连带责任,本站不承担任何法律及连带责任,请遵守中华人民共和国安全法.
  • 我的微信
  • 微信扫一扫
  • weinxin
  • 我的微信公众号
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2022年7月2日15:26:12
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                  【漏洞通告】Apache Tomcat 拒绝服务漏洞CVE-2022-29885 http://cn-sec.com/archives/1151448.html

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: