【漏洞通告】PHP Password_verify()验证错误漏洞(CVE-2023-0567)

admin 2023年3月7日14:35:55评论160 views1字数 989阅读3分17秒阅读模式
一、漏洞概述
CVE   ID
CVE-2023-0567
发现时间
2023-03-06
类    型
验证错误
等    级
高危
远程利用
所需权限
攻击复杂度
用户交互
PoC/EXP
已公开
在野利用

3月6日,启明星辰VSRC监测到PHP项目发布安全公告,修复了PHP Password_verify()函数中的一个验证错误漏洞(CVE-2023-0567),该漏洞的CVSSv3评分为7.7,目前其漏洞细节及PoC已经公开披露。

Password_verify() 函数用于验证密码是否和散列值(hash)匹配。由于PHP多个版本在Password_verify()中存在验证错误问题,当对于格式错误的BCrypt散列如果在其salt部分中包含$,将触发缓冲区过度读取,并可能导致将任何密码验证为有效。威胁者可以通过将此类无效散列存储在数据库中(如通过SQL注入等),则可能导致无需密码即可登录。


二、影响范围

8.0.x <= PHP版本<= 8.0.28

8.1.x <= PHP版本<= 8.1.16

8.2.x <= PHP版本<= 8.2.3


三、安全措施

3.1 升级版本

目前该漏洞已经修复,受影响用户可升级到以下版本:

PHP 8.0.x 用户:升级到补丁版本8.0.28或更高版本;

PHP 8.1.x用户:升级到补丁版本8.1.16或更高版本;

PHP 8.2.x用户:升级到补丁版本8.2.3或更高版本。

下载链接:

https://github.com/php/php-src/tags

3.2 临时措施

暂无。

3.3 通用建议

定期更新系统补丁,减少系统漏洞,提升服务器的安全性。

加强系统和网络的访问控制,修改防火墙策略,关闭非必要的应用端口或服务,减少将危险服务(如SSH、RDP等)暴露到公网,减少攻击面。

使用企业级安全产品,提升企业的网络安全性能。

加强系统用户和权限管理,启用多因素认证机制和最小权限原则,用户和软件权限应保持在最低限度。

启用强密码策略并设置为定期修改。

3.4 参考链接

https://github.com/php/php-src/security/advisories/GHSA-7fj2-8x79-rjf4

https://bugs.php.net/bug.php?id=81744


原文始发于微信公众号(维他命安全):【漏洞通告】PHP Password_verify()验证错误漏洞(CVE-2023-0567)

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2023年3月7日14:35:55
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   【漏洞通告】PHP Password_verify()验证错误漏洞(CVE-2023-0567)https://cn-sec.com/archives/1591713.html

发表评论

匿名网友 填写信息