【漏洞通告】pgAdmin 4远程命令执行漏洞(CVE-2023-5002)

admin 2024年5月14日21:56:36评论12 views字数 881阅读2分56秒阅读模式
一、漏洞概述
CVE   ID
CVE-2023-5002
发现时间
2023-09-25
类    型
命令执行
等    级
中危
攻击向量
网络
所需权限
攻击复杂度
用户交互
需要
PoC/EXP
未公开
在野利用
未发现

pgAdmin 4是一款专门针对PostgreSQL数据库的客户端管理软件。

9月25日,启明星辰VSRC监测到pgAdmin 4中存在一个远程命令执行漏洞(CVE-2023-5002),该漏洞的CVSSv3评分为6.0。

pgAdmin 4服务器中的HTTP API旨在用于验证用户选择的外部 PostgreSQL 实用程序(如 pg_dump 和 pg_restore)的路径,该实用程序由服务器执行以确定它来自哪个PostgreSQL版本。由于pgAdmin 4 v7.6及之前的版本中无法正确控制在此API上执行的服务器代码,经过身份验证的用户可将命令作为文件名,并使用API检查是否验证路径,可能导致将命令注入路径验证器并在pgAdmin 4服务器上执行该命令。

二、影响范围

pgAdmin 4版本<= 7.6

三、安全措施

3.1 升级版本

目前该漏洞已经修复,受影响用户可升级到pgAdmin 4 v7.7。

下载链接:

https://www.pgadmin.org/docs/pgadmin4/7.7/release_notes_7_7.html

3.2 临时措施

暂无。

3.3 通用建议

定期更新系统补丁,减少系统漏洞,提升服务器的安全性。

加强系统和网络的访问控制,修改防火墙策略,关闭非必要的应用端口或服务,减少将危险服务(如SSH、RDP等)暴露到公网,减少攻击面。

使用企业级安全产品,提升企业的网络安全性能。

加强系统用户和权限管理,启用多因素认证机制和最小权限原则,用户和软件权限应保持在最低限度。

启用强密码策略并设置为定期修改。

3.4 参考链接

https://github.com/pgadmin-org/pgadmin4/issues/6763

https://www.pgadmin.org/

原文始发于微信公众号(维他命安全):【漏洞通告】pgAdmin 4远程命令执行漏洞(CVE-2023-5002)

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2024年5月14日21:56:36
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   【漏洞通告】pgAdmin 4远程命令执行漏洞(CVE-2023-5002)https://cn-sec.com/archives/2066272.html

发表评论

匿名网友 填写信息