漏洞预警 | Apache Superset跨站脚本攻击漏洞

admin 2023年12月2日13:25:58评论16 views字数 419阅读1分23秒阅读模式
0x00 漏洞编号
  • CVE-2023-43701

0x01 危险等级
  • 中危
0x02 漏洞概述

Apache Superset是一个现代的、企业级的数据可视化和数据探索的网络应用程序。它可以连接多种数据源,提供各种图表选项,让不同技能水平的用户都能轻松地分析和呈现数据。

漏洞预警 | Apache Superset跨站脚本攻击漏洞

0x03 漏洞详情

CVE-2023-43701
漏洞类型:跨站脚本
影响:获取敏感数据
简述:Apache Superset在2.1.2之前版本中存在跨站脚本攻击漏洞,经过身份认证的攻击者可以通过不完善的有效载荷认证和REST API响应类型将恶意代码存入Chart的元数据中,当有用户访问特定的API端点时,恶意代码将被执行。

0x04 影响版本
  • Apache Superset < 2.1.2

0x05 修复建议

目前官方已发布漏洞修复版本,建议用户升级到安全版本
https://superset.apache.org/


原文始发于微信公众号(浅安安全):漏洞预警 | Apache Superset跨站脚本攻击漏洞

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2023年12月2日13:25:58
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   漏洞预警 | Apache Superset跨站脚本攻击漏洞https://cn-sec.com/archives/2262006.html

发表评论

匿名网友 填写信息