【已复现】Apache OFBiz 远程代码执行漏洞(CVE-2023-49070)安全风险通告

admin 2023年12月11日15:18:33评论30 views字数 1833阅读6分6秒阅读模式

● 点击↑蓝字关注我们,获取更多安全风险通告



漏洞概述

漏洞名称

Apache OFBiz 远程代码执行漏洞

漏洞编号

QVD-2023-46273、CVE-2023-49070

公开时间

2023-12-05

影响对象数量级

万级

奇安信评级

高危

CVSS 3.1分数

9.8

威胁类型

代码执行

利用可能性

POC状态

已公开

在野利用状态

未发现

EXP状态

未公开

技术细节状态

已公开

危害描述:未授权的攻击者可以在目标服务器上执行任意代码。


(注:奇安信CERT的漏洞深度分析报告包含此漏洞的POC及技术细节,订阅方式见文末。)


01
漏洞详情
>>>>

影响组件

Apache OFBiz是一个电子商务平台,用于构建大中型企业级、跨平台、跨数据库、跨应用服务器的多层、分布式电子商务类应用系统。


>>>>

漏洞描述

近日,奇安信CERT监测到 Apache OFBiz 远程代码执行漏洞(CVE-2023-49070),由于XML-RPC仍然存在于Apache Ofbiz 18.12.10之前的版本,远程未授权攻击者可绕过防护措施访问/webtools/control/xmlrpc利用此漏洞导致任意代码执行,接管目标服务器。


鉴于该漏洞影响范围较大,建议客户尽快做好自查及防护。



02
影响范围
>>>>

影响版本

Apache OFBiz < 18.12.10


>>>>

不受影响版本

Apache OFBiz >= 18.12.10


>>>>

其他受影响组件



03
复现情况

目前,奇安信CERT已成功复现Apache OFBiz 远程代码执行漏洞(CVE-2023-49070),截图如下:

【已复现】Apache OFBiz 远程代码执行漏洞(CVE-2023-49070)安全风险通告




04
处置建议
>>>>

安全更新

目前官方已有可更新版本,建议受影响用户升级至:

Apache OFBiz >= 18.12.10


>>>>

缓解措施

1.通过网络层面的访问控制,限制对XML-RPC接口的访问;

2.XML-RPC接口若非必须,可以考虑暂时禁用该接口。


>>>>

产品解决方案

奇安信自动化渗透测试系统检测方案

奇安信自动化渗透测试系统已经能够有效检测针对该漏洞的攻击,请将插件版本和指纹版本升级到20230120811600以上版本。规则名称:Apache OFBiz CVE-2023-49070 远程代码执行漏洞。奇安信自动化渗透测试系统规则升级方法:系统管理->升级管理->插件升级(指纹升级),选择“网络升级”或“本地升级”。


奇安信开源卫士已支持

奇安信开源卫士20231207. 465版本已支持对Apache OFBiz远程代码执行漏洞(CVE-2023-49070)的检测。


奇安信天眼检测方案

奇安信天眼新一代安全感知系统已经能够有效检测针对该漏洞的攻击,请将规则版本升级到3.0.1207.14139或以上版本。规则ID及规则名称:0x10021929,Apache Ofbiz远程代码执行漏洞(CVE-2023-49070)。奇安信天眼流量探针规则升级方法:系统配置->设备升级->规则升级,选择“网络升级”或“本地升级”。


Snort检测方案

Snort是一个开源的入侵检测系统,使用规则来检测网络流量中的恶意行为。用户可参考以下Snort检测规则,进行Apache OFBiz 远程代码执行漏洞(CVE-2023-49070)的检测:alert tcp $EXTERNAL_NET any -> $HOME_NET any (msg:"CVE-2023-49070 Apache OFBiz RCE"; flow:to_server,established; content:"/webtools/control/xmlrpc"; http_uri; content:"?USERNAME="; classtype:attempted-user; sid:1000001; rev:1;)



05
参考资料

[1]https://ofbiz.apache.org/release-notes-18.12.10.html

[2]https://www.openwall.com/lists/oss-security/2023/12/04/2



06
时间线

2023年12月7日,奇安信 CERT发布安全风险通告。



07
漏洞情报服务

奇安信ALPHA威胁分析平台已支持漏洞情报订阅服务:

【已复现】Apache OFBiz 远程代码执行漏洞(CVE-2023-49070)安全风险通告


【已复现】Apache OFBiz 远程代码执行漏洞(CVE-2023-49070)安全风险通告


【已复现】Apache OFBiz 远程代码执行漏洞(CVE-2023-49070)安全风险通告
奇安信 CERT
致力于第一时间为企业级用户提供权威漏洞情报和有效解决方案。

















点击↓阅读原文,到ALPHA威胁分析平台订阅更多漏洞信息。

原文始发于微信公众号(奇安信 CERT):【已复现】Apache OFBiz 远程代码执行漏洞(CVE-2023-49070)安全风险通告

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2023年12月11日15:18:33
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   【已复现】Apache OFBiz 远程代码执行漏洞(CVE-2023-49070)安全风险通告https://cn-sec.com/archives/2277071.html

发表评论

匿名网友 填写信息