漏洞预警 | Elasticsearch-Hadoop反序列化漏洞

admin 2023年12月8日12:43:27评论72 views字数 502阅读1分40秒阅读模式
0x00 漏洞编号
  • CVE-2023-46674

0x01 危险等级
  • 高危
0x02 漏洞概述

Elasticsearch-Hadoop是一组开源工具,用于实现Elasticsearch与Hadoop生态系统的集成。这个工具集的目标是使用户能够在使用Hadoop技术处理大数据的同时,能够无缝地将数据索引到Elasticsearch中进行搜索和分析。

漏洞预警 | Elasticsearch-Hadoop反序列化漏洞

0x03 漏洞详情

CVE-2023-46674
漏洞类型:反序列化
影响:执行任意代码
简述:Elasticsearch-Hadoop在7.17.11之前版本和8.9.0之前版本存在反序列化漏洞,经过身份认证的攻击者可以修改hadoop和spark配置属性,从而进行反序列化利用。

0x04 影响版本
  • Elasticsearch-hadoop < 7.17.11

  • 8.0.0 <= Elasticsearch-hadoop < 8.9.0

0x05 修复建议

目前官方已发布漏洞修复版本,建议用户升级到安全版本
https://github.com/elastic/elasticsearch-hadoop


原文始发于微信公众号(浅安安全):漏洞预警 | Elasticsearch-Hadoop反序列化漏洞

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2023年12月8日12:43:27
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   漏洞预警 | Elasticsearch-Hadoop反序列化漏洞https://cn-sec.com/archives/2279548.html

发表评论

匿名网友 填写信息