CVE-2024-0199|GitLab 身份验证绕过漏洞

admin 2024年3月9日15:11:54评论81 views字数 587阅读1分57秒阅读模式

0x00 前言

GitLab 是一个用于仓库管理系统的开源项目,使用Git作为代码管理工具,并在此基础上搭建起来的Web服务。

Gitlab是被广泛使用的基于git的开源代码管理平台, 基于Ruby on Rails构建, 主要针对软件开发过程中产生的代码和文档进行管理。

0x01 漏洞描述

漏洞允许攻击者绕过codeowners验证,在旧功能分支中利用精心构造的有效负载执行恶意操作,成功利用此漏洞可以实现对代码和数据进行未授权访问和修改。

0x02 CVE编号

CVE-2024-0199

0x03 影响版本

11.3 <= GitLab CE < 16.7.7

16.7.6 <= GitLab CE < 16.8.4

16.8.3 <= GitLab CE < 16.9.2

11.3 <= GitLab EE < 16.7.7

16.7.6 <= GitLab EE < 16.8.4

16.8.3 <= GitLab EE < 16.9.2

0x04 漏洞详情

https://hackerone.com/reports/2295423

0x05 参考链接

https://about.gitlab.com/releases/2024/03/06/security-release-gitlab-16-9-2-released/

原文始发于微信公众号(信安百科):CVE-2024-0199|GitLab 身份验证绕过漏洞

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2024年3月9日15:11:54
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   CVE-2024-0199|GitLab 身份验证绕过漏洞https://cn-sec.com/archives/2558878.html

发表评论

匿名网友 填写信息