【漏洞通告】GeoServer文件上传代码执行漏洞(CVE-2023-51444)

admin 2024年3月22日19:24:40评论203 views字数 909阅读3分1秒阅读模式

一、漏洞概述

漏洞名称

  GeoServer文件上传代码执行漏洞

CVE   ID

CVE-2023-51444

漏洞类型

文件上传

发现时间

2024-03-21

漏洞评分

7.2

漏洞等级

高危

攻击向量

网络

所需权限

利用难度

用户交互

PoC/EXP

已公开

在野利用

未知

GeoServer是一个用 Java 编写的开源软件服务器,允许用户共享和编辑地理空间数据。
2024年3月21日,启明星辰VSRC监测到GeoServer中修复了一个任意文件上传漏洞(CVE-2023-51444),其CVSS评分为7.2,目前该漏洞的PoC已公开。
GeoServer 2.23.4和2.24.1之前版本中存在任意文件上传漏洞,可能导致经过身份验证的威胁者通过 REST Coverage Store API 修改覆盖率存储,将任意文件内容上传到任意文件位置,从而导致远程代码执行。

二、影响范围

GeoServer < 2.23.4
2.24.0 <= GeoServer < 2.24.1

三、安全措施

3.1 升级版本

目前该漏洞已经修复,受影响用户可升级到GeoServer 2.23.4、2.24.1或更高版本。
下载链接:
https://github.com/geoserver/geoserver/releases

3.2 临时措施

暂无。

3.3 通用建议

定期更新系统补丁,减少系统漏洞,提升服务器的安全性。
加强系统和网络的访问控制,修改防火墙策略,关闭非必要的应用端口或服务,减少将危险服务(如SSH、RDP等)暴露到公网,减少攻击面。
使用企业级安全产品,提升企业的网络安全性能。
加强系统用户和权限管理,启用多因素认证机制和最小权限原则,用户和软件权限应保持在最低限度。
启用强密码策略并设置为定期修改。

3.4 参考链接

https://github.com/geoserver/geoserver/security/advisories/GHSA-9v5q-2gwq-q9hq

https://github.com/geoserver/geoserver/pull/7222

原文始发于微信公众号(启明星辰安全简讯):【漏洞通告】GeoServer文件上传代码执行漏洞(CVE-2023-51444)

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2024年3月22日19:24:40
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   【漏洞通告】GeoServer文件上传代码执行漏洞(CVE-2023-51444)https://cn-sec.com/archives/2596063.html

发表评论

匿名网友 填写信息