【漏洞通告】JumpServer多个高危漏洞安全风险通告

admin 2024年4月3日15:54:18评论27 views字数 709阅读2分21秒阅读模式

漏洞背景

近日,嘉诚安全监测到JumpServer官方发布新版本,修复了JumpServer远程代码执行漏洞(CVE-2024-29201)和JumpServer 后台模板注入漏洞(CVE-2024-29202)。

JumpServer 是广受欢迎的开源堡垒机,是符合4A 规范的专业运维安全审计系统,可以帮助企业以更安全的方式管控和登录各种类型的资产。

鉴于漏洞危害较大,嘉诚安全提醒相关用户尽快更新至安全版本,避免引发漏洞相关的网络安全事件。

漏洞详情

1.CVE-2024-29201

JumpServer远程代码执行漏洞,经研判,该漏洞为高危漏洞。具有低权限用户帐户的攻击者可通过构建恶意playbook模板绕过Ansible中的输入验证机制,从而在Celery容器中执行任意代码。

2.CVE-2024-29202

JumpServer JINJA2注入代码执行漏洞,经研判,该漏洞为高危漏洞,PoC/EXP已公开。具有低权限用户帐户的攻击者可通过构建恶意playbook模板利用Ansible中的Jinja2模板代码注入漏洞在Celery容器中执行任意代码。由于Celery容器以root权限运行并具有数据库访问权限,因此攻击者可以从所有主机窃取敏感信息或操纵数据库。

危害影响

影响版本

v3.0.0 <= JumpServer <= v3.10.6

修复建议

目前这些漏洞已经修复,受影响用户可升级到JumpServer v3.10.7或更高版本。

下载链接:

https://github.com/jumpserver/jumpserver/releases

【漏洞通告】JumpServer多个高危漏洞安全风险通告【漏洞通告】JumpServer多个高危漏洞安全风险通告

原文始发于微信公众号(嘉诚安全):【漏洞通告】JumpServer多个高危漏洞安全风险通告

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2024年4月3日15:54:18
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   【漏洞通告】JumpServer多个高危漏洞安全风险通告https://cn-sec.com/archives/2627258.html

发表评论

匿名网友 填写信息