思科交换机配置指引(包含安全配置部分)以 Cisco WS-C3850-48T 配置为例

admin 2024年4月4日13:37:09评论3 views字数 2061阅读6分52秒阅读模式

思科Catalyst 3850系列交换机

  • 型号: Cisco WS-C3850-48T

  • 端口数: 48个10/100/1000Mbps数据端口

  • 供电方式:AC电源(支持PoE+)

  • 堆叠技术:Cisco StackWise-480,提供480Gbps的堆叠吞吐量

  • 网络模块:支持多种可选上行链路模块,包括千兆位以太网、万兆位以太网和40千兆位以太网端口

目录

  1. 基础配置

  2. VLAN 配置

  3. STP 配置

  4. QoS 配置

  5. 安全配置

  6. 其他配置

思科交换机配置指引(包含安全配置部分)以 Cisco WS-C3850-48T 配置为例

1. 基础配置

1.1 设置交换机 IP 地址

hostname Switch1 # 设置交换机主机名ip domain-name example.com # 设置域名ip domain-lookup # 启用域名解析ip address 10.1.1.1 255.255.255.0 # 设置交换机 IP 地址和子网掩码

1.2 设置登录密码

username admin password cisco # 设置管理员账号和密码line vty 0 4 # 配置虚拟终端行transport input ssh # 启用 SSH 登录login local # 使用本地数据库进行身份验证

1.3 启用 SNMP

snmp-server community public # 启用 SNMP 并设置公共社区名

1.4 设置时间

clock timezone Asia/Shanghai # 设置时区

2. VLAN 配置

2.1 创建 VLAN

vlan 10 # 创建 VLAN 10name Marketing # 设置 VLAN 名称

2.2 将端口分配给 VLAN

interface range gi1/1 - gi1/24 # 选择端口范围switchport mode access # 设置端口模式为接入模式switchport access vlan 10 # 将端口分配给 VLAN 10

3. STP 配置

3.1 启用 STP

spanning-tree mode network # 启用 STP 并将其模式设置为网络模式

3.2 设置 STP 优先级

spanning-tree priority 1 # 设置交换机的 STP 优先级

4. QoS 配置

4.1 创建 QoS 策略

qos policy-map my-policy # 创建 QoS 策略class class-1 # 创建第一个类  bandwidth 1000000 # 设置第一个类的带宽class class-2 # 创建第二个类  bandwidth 500000 # 设置第二个类的带宽

4.2 将 QoS 策略应用于端口

interface gi1/1 # 选择端口switchport mode access # 设置端口模式为接入模式switchport access vlan 10 # 将端口分配给 VLAN 10qos policy-map my-policy in # 将 QoS 策略应用于入方向流量

5. 安全配置

5.1 启用端口安全

interface gi1/1 # 选择端口switchport port-security # 启用端口安全switchport port-security maximum 2 # 设置最大允许 MAC 地址数为 2

5.2 配置 MAC 地址认证

interface gi1/1 # 选择端口switchport mode access # 设置端口模式为接入模式switchport access vlan 10 # 将端口分配给 VLAN 10switchport port-security mac-address sticky # 启用 MAC 地址认证并设置 MAC 地址为永久

5.3 配置 802.1X 认证

aaa new-model # 创建 AAA 模型aaa authentication dot1x default group radius # 将默认认证方法设置为 802.1X 并使用 RADIUS 服务器aaa authorization exec default group radius # 将默认授权方法设置为 RADIUS 服务器aaa accounting network default start-stop group radius # 将默认计费方法设置为 RADIUS 服务器radius-server host 10.1.1.2 # 设置 RADIUS 服务器 IP 地址radius-server key cisco # 设置 RADIUS 服务器密钥

6. 其他配置

6.1 配置 DHCP 服务器

ip dhcp pool my-pool # 创建 DHCP 服务器池network 10.1.1.0 255.255.255.0 # 设置 IP 地址范围default-router 10.1.1.1 # 设置默认网关dns-server 10.1.1.2 # 设置 DNS 服务器

6.2 配置 NTP 服务器

ntp server 10.1.1.2 # 设置 NTP 服务器 IP 地址

6.3 配置 SSH 登录

ip domain-name example.com # 设置域名crypto key generate rsa modulus 2048 # 生成 RSA 密钥line vty 0 4 # 配置虚拟终端行transport input ssh # 启用 SSH 登录login local # 使用本地数据库进行身份验证

注意: 以上配置仅供参考,请根据您的实际需求进行调整。

原文始发于微信公众号(技术修道场):思科交换机配置指引(包含安全配置部分)以 Cisco WS-C3850-48T 配置为例

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2024年4月4日13:37:09
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   思科交换机配置指引(包含安全配置部分)以 Cisco WS-C3850-48T 配置为例https://cn-sec.com/archives/2630585.html

发表评论

匿名网友 填写信息