【漏洞通告】pgAdmin后台远程命令执行漏洞(CVE-2024-3116)

admin 2024年4月19日22:34:45评论24 views字数 790阅读2分38秒阅读模式

【漏洞通告】pgAdmin后台远程命令执行漏洞(CVE-2024-3116)

01 漏洞概况

pgAdmin是PostgreSQL的官方图形界面管理工具,以便于管理和维护PostgreSQL数据库。测到pgAdmin中修复了一个远程代码执行漏洞(CVE-2024-3116),其CVSS评分为7.4,目前该漏洞的细节及PoC已公开。pgAdmin版本<=8.4中,当运行在Windows平台上时,由于对文件路径验证不充分,经过身份验证的威胁者可利用validate_binary_path接口构造恶意请求导致远程代码执行,成功利用该漏洞可能导致远程执行命令并控制目标系统。

02 漏洞处置

综合处置优先级:

漏洞信息

漏洞名称

pgAdmin后台远程命令执行漏洞

漏洞编号

CVE编号

CVE-2024-3116

漏洞评估

披露时间

2024-03-03

漏洞类型

命令执行

危害评级

高危

公开程度

PoC公开

威胁类型

远程

利用情报

在野利用

影响产品

产品名称

pgAdmin

受影响版本

影响范围

广

有无修复补丁

03 漏洞排查

pgAdmin8.5或更低版本会受到影响若存在应用使用,极大可能会受到影响。(根据漏洞实际排查方案来写)

04 修复方案

1、官方修复方案

当前官方已发布最新版本,建议受影响的用户及时更新升级到最新版本。链接如下:

目前该漏洞已经修复,受影响用户可升级到pgAdmin8.5或更高版本,定期更新系统补丁,减少系统漏洞,提升服务器的安全性。

加强系统和网络的访问控制,修改防火墙策略,关闭非必要的应用端口或服务,减少将危险服务(如SSH、RDP等)暴露到公网,减少攻击面。下载链接:

https://www.pgadmin.org/download/

05 时间线

  2024.04.03 厂商发布安全补丁
      2024.04.09 安迈信科安全运营团队发布通告
   

原文始发于微信公众号(安迈信科应急响应中心):【漏洞通告】pgAdmin后台远程命令执行漏洞(CVE-2024-3116)

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2024年4月19日22:34:45
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   【漏洞通告】pgAdmin后台远程命令执行漏洞(CVE-2024-3116)https://cn-sec.com/archives/2648840.html

发表评论

匿名网友 填写信息