Linux 内核修复5个高危漏洞

  • A+
所属分类:安全漏洞

Linux 内核修复5个高危漏洞 聚焦源代码安全,网罗国内外最新资讯!

作者: Steven J. Vaughan-Nichols

编译:奇安信代码卫士团队


Positive Technologies 公司的Linux 安全开发员 Alexander Popov 在 Linux 内核的虚拟套接字实现中发现了5个漏洞。攻击者可利用这些漏洞 (CVE-2021-26708) 获得root 权限并对服务器发起拒绝服务攻击。
Linux 内核修复5个高危漏洞
Linux 内核修复5个高危漏洞


这些漏洞的 CVSS v3 评分为7.0,属于“高危”级别,Linux 管理员应尽快修复这些系统。

虽然 Popov 是在 Red Hat 的社区 Linux 发行版 Fedora 33 Server 中发现这些漏洞的,但它存在于使用 Linux 内核(自2019年11月的版本 5.5 起至当前的主流版本 5.11-rc6)中。

虚拟套接字的多传输支持功能添加后,这些漏洞就被引入 Linux 中。该网络传输方便了虚拟机及其主机之间的通信,guest 代理和管理服务常用它作为独立于虚拟机网络配置的通信信道。由于如今几乎所有人都在云上运行虚拟机,因此均易受攻击。

漏洞的核心问题在于 CONFIG_VSOCKETS 和 CONFIG_VIRTIO_VSOCKETS 内核驱动中的竞争条件。它们是所有 Linux 主流发行版本中的内核模块。这些漏洞之所以严重的原因在于无论普通用户何时创建 AF_VSOCK 套接字,易受攻击的模块都会自动加载。当系统的实质行为取决于不可控制事件的顺序或事件时,就会存在竞争条件。

Popov 表示,“我成功地为 Fedora 33 Server 开发出了本地提权原型 exploit,绕过 x86_64 平台防护措施如 SMEP 和 SMAP。这项研究将提出如何改善 Linux 内核安全的新理念。”

同时,Popov 还准备了补丁并向Linux 安全团队提交报告。Linux 内核稳定版首席维护师 Greg Kroah-Hartman 在2月3日接受了补丁并发布在 Linux 5.10.13 中。之后补丁被集成到主流版本 5.11-rc7 中并向后移植到受影响的稳定树中。

补丁已被集成到流行的 Linux 发行版本中如 Red Hat Enterprise Linux (RHEL) 8、Debian、Ubuntu 和 SUSE。

Popov 此前发行并修复了多个 Linux 内核漏洞,如 CVE-2019-18683 和 CVE-2017-2636。




推荐阅读

Windows 和 Linux 服务器遭新型僵尸网络 WatchDog 攻击近两年
谷歌:注意 Linux 内核中严重的零点击 “BleedingTooth” 蓝牙缺陷



原文链接

https://www.zdnet.com/article/linux-network-security-holes-found-fixed/



题图:Pixabay License


本文由奇安信代码卫士编译,不代表奇安信观点。转载请注明“转自奇安信代码卫士 https://codesafe.qianxin.com”。



Linux 内核修复5个高危漏洞
Linux 内核修复5个高危漏洞

奇安信代码卫士 (codesafe)

国内首个专注于软件开发安全的

产品线。

   Linux 内核修复5个高危漏洞 觉得不错,就点个 “在看” 或 "” 吧~



本文始发于微信公众号(代码卫士):Linux 内核修复5个高危漏洞

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: