微信小程序强制开启开发者工具(非常详细)

admin 2024年6月11日14:24:03评论8 views字数 1073阅读3分34秒阅读模式

支持版本列表

感谢志远大佬的WeChatOpenDevTool开源 代码只是把node改用python3重写,简单实现了一些自动化问题,重要代码都是原作者的。

Windows 微信版本 小程序版本 是否为最新版
3.9.10.19_x64 9129_x64
3.9.10.19_x64 9115_x64
3.9.10.19_x64 8555_x64
3.9.10.19_x64 9105_x64
3.9.9.43_x64 8555_x64
3.9.9.43_x64 9079_x64
3.9.8.25_x64 8531_x64
3.9.8.25_x64 8529_x64
3.9.8.25_x64 8519_x64
3.9.8.25_x64 8501_x64
3.9.8.25_x64 8461_x64
3.9.8.25_x64 8447_x64
Mac x64微信版本 是否为最新版 x
MacWechat/3.8.8(0x13080811) 点我下载

如何查看当前运行版本?

windows

微信小程序强制开启开发者工具(非常详细)

微信小程序强制开启开发者工具(非常详细) 微信小程序强制开启开发者工具(非常详细)

mac

ps aux | grep 'WeChatAppEx' |  grep -v 'grep' | grep  "wmpf-mojo-handle"

食用方法

开启小程序F12

只支持windows版本微信,运行前先启动微信运行前先启动微信(建议小号,别被封了。。。)

  1. 安装python3版本
  2. 下载WeChatOpenDevTools-Python或直接下载编译好的exe WeChatOpenDevTools_64.exe

安装依赖

pip3  install -r requirements.txt

运行✅

python main.py -x

微信小程序强制开启开发者工具(非常详细) 微信小程序强制开启开发者工具(非常详细)

开启微信内置浏览器F12

python  main.py -c

微信小程序强制开启开发者工具(非常详细)

微信小程序强制开启开发者工具(非常详细)

微信小程序强制开启开发者工具(非常详细)

常见问题

  • 无法修改中文

    • yes
  • 提示找不到版本或微信未运行❌

    • 如果还有问题看:微信版本和小程序版本都是符合要求的,但是仍然显示“未找到匹配版本的微信进程或微信未运行”
    1. 请先看支持的微信版本和小程序版本
    2. 如果微信版本相同小程序版本不同,就删除小程序版本目录并重启微信,直到刷出支持的小程序版本目录
    3. 最后回到上级目录,设置文件夹权限为只读,这样就能一直保持小程序版本一致 image
  • mac版本闪退

    • macOS版本不能和windows版本一样随时hook小程序修改F12,只能先加载小程序后再hook(必须是有小程序缓存了,不然会闪退)
    • 可以先启动多个需要调试的小程序后再运行软件然后再刷新小程序

下载

https://github.com/x0tools/WeChatOpenDevTools

原文始发于微信公众号(TKing的安全圈):微信小程序强制开启开发者工具(非常详细)

 

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2024年6月11日14:24:03
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   微信小程序强制开启开发者工具(非常详细)https://cn-sec.com/archives/2836736.html

发表评论

匿名网友 填写信息