【漏洞通告】Openssh权限提升漏洞 CVE-2021-41617

  • A+
所属分类:安全漏洞

漏洞名称 Openssh权限提升漏洞 CVE-2021-41617

组件名称 : Openssh

影响范围 : 6.2≤Openssh<8.8

漏洞类型 : 配置不当

利用条件 :

1、用户认证:需要用户认证
2、触发方式:本地

综合评价 :

<综合评定利用难度>:未知。

<综合评定威胁等级>:中危,可导致权限提升。


漏洞分析


组件介绍

    Openssh 是 SSH 协议的免费开源实现,可以用来进行远程控制, 或在计算机之间传送文件。通过对交互的流量进行加密防止窃听,连接劫持以及其他攻击。Openssh由OpenBSD项目的一些开发人员实现,已被集成到多种开源和商业产品中。


2 漏洞描述

    近日,深信服安全团队监测到一则Openssh组件存在堆溢出漏洞的信息,漏洞编号:CVE-2021-41617,漏洞威胁等级:中危。

    该漏洞是由于Openssh在使用某些非默认配置时,未能正确对补充组进行初始化,在执行AuthorizedKeysCommand 或 AuthorizedPrincipalsCommand指令时,帮助程序使用与 sshd 进程的组成员身份相关联的权限运行,攻击者可利用该漏洞在低权限的情况下,执行权限提升攻击,最终可获取其他用户的权限。


影响范围


    Openssh是多数Linux发行版系统默认的SSH协议实现,由于其功能强大,所以被广泛使用。可能受漏洞影响的资产广泛分布于世界各地,此次曝出的漏洞为中危漏洞,但涉及用户量大,故漏洞影响力较大。

    目前受影响的Openssh版本:

6.2≤Openssh<8.8


解决方案


1 如何检测组件系统版本

    执行命令

ssh -V

    以查看Openssh版本。

【漏洞通告】Openssh权限提升漏洞 CVE-2021-41617


2 官方修复建议

    当前官方已发布最新版本,建议受影响的用户及时更新升级到最新版本。链接如下:

http://www.openssh.com/


时间轴


2021/9/27    深信服监测到Libssh堆溢出漏洞攻击信息。

2021/9/28    深信服千里目安全实验室发布漏洞通告。


参考链接


https://www.openssh.com/txt/release-8.8


点击阅读原文,及时关注并登录深信服智安全平台,可轻松查询漏洞相关解决方案。

【漏洞通告】Openssh权限提升漏洞 CVE-2021-41617


深信服千里目安全实验室

【漏洞通告】Openssh权限提升漏洞 CVE-2021-41617

深信服科技旗下安全实验室,致力于网络安全攻防技术的研究和积累,深度洞察未知网络安全威胁,解读前沿安全技术。

● 扫码关注我们


本文始发于微信公众号(深信服千里目安全实验室):【漏洞通告】Openssh权限提升漏洞 CVE-2021-41617

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: