漏洞预警 | PyDrive2 YAML反序列化漏洞

admin 2023年12月9日13:49:58评论20 views字数 414阅读1分22秒阅读模式
0x00 漏洞编号
  • CVE-2023-49297

0x01 危险等级
  • 高危
0x02 漏洞概述

PyDrive2是一个用于Python编程语言的开源库,可以方便地与Google Drive进行交互。

漏洞预警 | PyDrive2 YAML反序列化漏洞

0x03 漏洞详情

CVE-2023-49297
漏洞类型:反序列化
影响:执行任意代码
简述:PyDrive2在1.17.0和1.16.1及之前版本中存在反序列化漏洞,由于PyDrive2会通过LoadSettingsFile函数加载YAML文件,且没有对YAML文件的内容进行过滤,当攻击者可以配置恶意YAML文件使其进行加载,从而导致任意代码执行利用。

0x04 影响版本
  • PyDrive2 1.17.0

  • PyDrive2 <= 1.16.1

0x05 修复建议

目前官方已发布漏洞修复版本,建议用户升级到安全版本
https://github.com/iterative/PyDrive2


原文始发于微信公众号(浅安安全):漏洞预警 | PyDrive2 YAML反序列化漏洞

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2023年12月9日13:49:58
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   漏洞预警 | PyDrive2 YAML反序列化漏洞http://cn-sec.com/archives/2282484.html

发表评论

匿名网友 填写信息