【漏洞通告】JetBrains IntelliJ IDE信息泄露漏洞(CVE-2024-37051)

admin 2024年7月3日08:14:45评论9 views字数 2083阅读6分56秒阅读模式
一、漏洞概述
漏洞名称
   JetBrains IntelliJ IDE信息泄露漏洞
CVE   ID
CVE-2024-37051
漏洞类型
信息泄露
发现时间
2024-06-12
漏洞评分
9.3
漏洞等级
高危
攻击向量
网络
所需权限
利用难度
用户交互
PoC/EXP
已公开
在野利用
未发现

JetBrains IntelliJ 是一个集成开发环境(IDE)平台,由 JetBrains 公司开发并维护,支持Java、Kotlin、Scala、Groovy、Python、JavaScript、TypeScript、Go、Rust 等多种编程语言。

2024年6月12日,启明星辰集团VSRC监测到 JetBrains IntelliJ IDE信息泄露漏洞(CVE-2024-37051)的漏洞细节及PoC/EXP在互联网上公开,该漏洞的CVSS评分为9.3。

JetBrains IntelliJ平台上的 JetBrains GitHub 插件中存在漏洞,当在 IDE中使用 GitHub 拉取请求功能时可能导致将访问令牌暴露给第三方主机,导致敏感信息泄露。该漏洞影响从2023.1 起启用并配置/使用JetBrains GitHub 插件的所有基于IntelliJ 的集成开发环境。

二、影响范围

IntelliJ IDE 2023.1及更高版本,其中启用并配置了JetBrains GitHub 插件

三、安全措施

3.1 升级版本

目前JetBrains已修复该漏洞,并修补了易受攻击的JetBrains GitHub 插件,并从其官方插件市场中删除了所有以前受影响的版本,IntelliJ IDE的完整修复版本列表包括:

Aqua:2024.1.2

CLion:2023.1.7, 2023.2.4, 2023.3.5, 2024.1.3, 2024.2 EAP2

DataGrip:2024.1.4

DataSpell:2023.1.6, 2023.2.7, 2023.3.6, 2024.1.2

GoLand:2023.1.6, 2023.2.7, 2023.3.7, 2024.1.3, 2024.2 EAP3

IntelliJ IDEA:2023.1.7, 2023.2.7, 2023.3.7, 2024.1.3, 2024.2 EAP3

MPS:2023.2.1, 2023.3.1, 2024.1 EAP2

PhpStorm:2023.1.6, 2023.2.6, 2023.3.7, 2024.1.3, 2024.2 EAP3

PyCharm:2023.1.6, 2023.2.7, 2023.3.6, 2024.1.3, 2024.2 EAP2

Rider:2023.1.7, 2023.2.5, 2023.3.6, 2024.1.3

RubyMine:2023.1.7, 2023.2.7, 2023.3.7, 2024.1.3, 2024.2 EAP4

RustRover:2024.1.1

WebStorm:2023.1.6, 2023.2.7, 2023.3.7, 2024.1.4

下载链接:

https://www.jetbrains.com/

3.2 临时措施

建议更新到的IDE的最新版本。

此外,如果在 IDE中使用 GitHub 拉取请求功能,建议撤销插件正在使用的任何 GitHub令牌。鉴于该插件可以使用 OAuth 集成或个人访问令牌 (PAT),请检查两者并根据需要撤销:

OAuth 集成设置:转到应用程序→ 授权的 OAuth 应用程序并撤销JetBrains IDE 集成应用程序的访问权限。

个人访问令牌设置:进入Tokens页面,删除为插件颁发的令牌。默认令牌名称为IntelliJ IDEA GitHub integration plugin,也可以使用自定义名称。

注意,令牌被撤销后,需要重新设置插件,因为所有插件功能(包括 Git操作)都将停止工作。此外,由于缓解措施,旧版本JetBrains IDE中的 JetBrains GitHub 插件可能无法再按预期工作。

3.3 通用建议

定期更新系统补丁,减少系统漏洞,提升服务器的安全性。

加强系统和网络的访问控制,修改防火墙策略,关闭非必要的应用端口或服务,减少将危险服务(如SSH、RDP等)暴露到公网,减少攻击面。

使用企业级安全产品,提升企业的网络安全性能。

加强系统用户和权限管理,启用多因素认证机制和最小权限原则,用户和软件权限应保持在最低限度。

启用强密码策略并设置为定期修改。

3.4 参考链接

https://blog.jetbrains.com/security/2024/06/updates-for-security-issue-affecting-intellij-based-ides-2023-1-and-github-plugin/

https://www.bleepingcomputer.com/news/security/jetbrains-warns-of-intellij-ide-bug-exposing-github-access-tokens/

原文始发于微信公众号(启明星辰安全简讯):【漏洞通告】JetBrains IntelliJ IDE信息泄露漏洞(CVE-2024-37051)

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2024年7月3日08:14:45
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   【漏洞通告】JetBrains IntelliJ IDE信息泄露漏洞(CVE-2024-37051)http://cn-sec.com/archives/2846294.html

发表评论

匿名网友 填写信息