【漏洞预警】pgAdmin远程代码执行漏洞(CVE-2024-3116)

admin 2024年4月10日12:43:00评论25 views字数 405阅读1分21秒阅读模式

【漏洞预警】pgAdmin远程代码执行漏洞(CVE-2024-3116)

漏洞描述:
pgAdmin是PostgreSQL的官方图形界面管理工具,以便于管理和维护PostgreSQL数据库,近日监测到pgAdmin中修复了一个远程代码执行漏洞CVE-2024-3116,其CVSS评分为7.4,目前该漏洞的细节及PoC已公开,pgAdmin版本<=8.4中,当运行在Windows平台上时,由于对文件路径验证不充分,经过身份验证的威胁者可利用validate_binary_path接口构造恶意请求导致远程代码执行,成功利用该漏洞可能导致远程执行命令并控制目标系统。

【漏洞预警】pgAdmin远程代码执行漏洞(CVE-2024-3116)

【漏洞预警】pgAdmin远程代码执行漏洞(CVE-2024-3116)

【漏洞预警】pgAdmin远程代码执行漏洞(CVE-2024-3116)

影响范围:

pgAdmin<= 8.4

安全措施:
升级版本
目前该漏洞已经修复,受影响用户可升级到pgAdmin8.5或更高版本

下载链接:
https://www.pgadmin.org/download/

临时措施:
暂无

原文始发于微信公众号(飓风网络安全):【漏洞预警】pgAdmin远程代码执行漏洞(CVE-2024-3116)

  • 左青龙
  • 微信扫一扫
  • weinxin
  • 右白虎
  • 微信扫一扫
  • weinxin
admin
  • 本文由 发表于 2024年4月10日12:43:00
  • 转载请保留本文链接(CN-SEC中文网:感谢原作者辛苦付出):
                   【漏洞预警】pgAdmin远程代码执行漏洞(CVE-2024-3116)https://cn-sec.com/archives/2639545.html

发表评论

匿名网友 填写信息